F31 wayland pauses and freezes under load (poor interactivity)

I had a problem similar to what’s described in this thread: Reddit - Dive into anything

The display would freeze and pause for seconds at a time (sometimes up to 10 or 20 seconds) and the mouse would be choppy. If I were in the middle of typing, when the system resumed, I’d get many repeats of whatever character had been delayed.

System top would show that kswap0 was eating CPU when the pauses happened. I am on a laptop with SSD, so this is odd-- swap has a bandwidth > 100+MB/s with negligible seek, so that’s a lot of pages.

I followed the thread and found another reddit thread about 5.3+ (except 5.3.14+) and 5.4+ being buggy with intel iGPUs: Reddit - Dive into anything .
I was running kernel 5.3.15, and I think the pauses had been happening since the last kernel upgrade to 5.3.14. So I said, well, maybe my problem is the inverse, so I rebooted to an earlier kernel 5.3.12-300.fc31.x86_64, and poof, the problem is completely gone. This is not to say it never pauses, but now the pauses are infrequent and last less than a second, even under load and memory pressure.

I am running an early 2015 Dell XPS13 with the i7-5500U and Intel HD5500 gpu.

Just sharing because I couldn’t find much other info on the same problem and the suggestions (add a kernel flag, switch to xorg) in the earlier thread were unsatisfactory to me. The kernel switch is fine. I locked my kernel with versionlock and will hold onto this kernel version. I was going nuts with the freezes (10 seconds every 10-20 minutes would drive anyone nuts, no?), so I just wanted the info to be out there.

working: vmlinuz-5.3.12-300.fc31.x86_64
(probably, didn’t retest) faulty: vmlinuz-5.3.14-300.fc31.x86_64
definitely faulty: vmlinuz-5.3.15-300.fc31.x86_64


Have you upgraded kernel since then?

I have started encountering the same issue of late, up the point where the machine rebooted itself. :confused:

Currently on x86_64 Linux 5.4.8-200.fc31.x86_64 on similar hardware: Dell XPS 13 with i7-7560U

1 Like

Not recently. I’ll probably check again in another couple weeks. This is my work laptop and my time for experimentation is a bit limited. If you know of some possibly relevant kernel changes, let me know.

1 Like

i do not know if it is related but i had this kind of behaviour already since earlier, symptoms mostly went away when i disabled the tracker, i guess though that that counts as painting over the symptoms rather than solving the problem (i would say that i have seen this behaviour the last few fedora releases though so not really that new)

I have consistently kept up to date with the kernel update, and I am currently on x86_64 Linux 5.7.8-200.fc32.x86_64, but the shutter still persist.

@enpontus, what is the tracker you are mentioning?

gnomes file indexer - google “tracker-miner-fs”

the computer on which i have seen this on has since died and is now resting in my garage on its final rest at the local recycling depot. My new computer does not show the same signs on a fresh F32 install…

Interesting; I’ve not come across that one before. The load incurred on my work laptop is mostly due to too many IDE loaded alongside the company mandated AV (savscan) kicking in.