Greatly worsened "micro-freezing" issue in F38 under Wayland (nouveau driver)

This may or may not be related to @nnhoang’s issue ‘Sticky’ or lagging windows after a few days of uptime; the symptoms are somewhat similar, but in my case the issuuuuuuuuuuuuuuuuuuuuuuuuue is farrrrrrrrrrrrrrrr worse since upgrading to F38.

This happened sometimes in F37, but only seemed to crop up with load so I assumed it was a swap/context-switch issue. (My machine isn’t particularly new or fast.) But now unnnnnnnnnnnnnnnnnnnnder F38 it’s a constant thing.

In my case, everything on the system is exhibitingggggggggggggggggggggggggggggggg “micro-freezes”, right down to theeeeeeeeeeeeeeeeee input level — like, those repeated characters (which I’d normally delete) are the result of one of those freezes hitting wwwwwwwwwwwwwwwwwwwhile I’m typing; if there’s a key down during the freeze, the system interppppppppppppppppprets it as me holding down the key for the length of the freeze.

The display output is also completely static for the length of the freeze, including the mouse pointer. The freezes don’t occur with annnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnny set timing, it can be anywhere from under a second to several seconds between them.

If I have a video playing in VLC, and open its Messages window with the verbosity set to Warnings, each freeze will be accompanied by a flurry of these messages:

main warning: picture is too late to be displayed (missing nn ms)

And sometimes (but far from every time), a typing freeze will result in a bunch of these messages in my user journal:

May 10 13:40:38 gnome-shell[131259]: Key repeat discarded, Wayland compositor doesn’t seem to be processing events fast enough!

So, there is some indication, and it seems Wayland is being fingered as the culprit.

I’m running on an El Cheapo Nvidia GT 710 GPU, using nouveau on Wayland. I haven’t tried Xorg yet, to see if it occurs there as well.

My GPU will occasionally “freak out” and dump a storm of errors into dmesg (it doesn’t seem to be perfectly supported under nouveau), very occasionally even taking down the GNOME Shell session completely and dumping me back to the greeter. But this issue isn’t predicated on that happening, and doesn’t seem to be directly related.

(Edit: I decided to try logging in to a “GNOME Valgrind (Errors)” session instead, not realizing it was an Xorg-based session — we should probably rename those (PR to do exactly that) — and so far, no freezing. Even despite the added load of valgrind watching the Xorg process.

Also, VLC for some reason has switched from dark- to light-mode styling for its internal widgets. …I will never understand how style preferences are handled. Why would the backend matter?)

Solved. Turns out, the issue was caused by having appimagelauncherd installed and enabled — a previously-reported issue with the daemon.

1 Like