External monitor not recognized over USB 4 docking station

I’m running Fedora 36 on a Thinkpad X13 with an AMD Ryzen 6850U with integrated AMD Radeon 680M graphics. This machine has a USB 4 port which, to my understanding, is supposed to be backwards compatible with Thunderbolt 3. Currently I’m running kernel 5.19.9.

I have a TB3 docking station that I was using previously with my work computer (mac) and my personal computer (Fedora 36, Dell XPS 15). The monitor is connected to the docking station via HDMI.

When I connect the Thinkpad to the docking station on kernel 5.19.9, no external monitor is detected at all. All other peripheral devices are detected, including my mouse, webcam, microphone, and keyboard. Furthermore, the docking station appears in settings as a capable TB3 device.

When running on kernel 5.17.x the external monitor shows up as an unrecognized device with a resolution of 640x480. The same is true when running on kernel 6.0.0-rc6 release candidates.

I am unsure where to proceed from here, as Fedora has worked flawlessly otherwise. I briefly tried Ubuntu which also expressed the same issues.

I’m hoping someone can help me debug the USB 4 scenario, as I believe that’s part of the problem. Everything I’ve read thus far has indicated that full USB 4 support landed in the Linux kernel a while ago, but I’m wondering if it’s incomplete.

Thank you!

Miscellaneous Info::

  • Connecting to the display with a simpler USB-C to HDMI dongle works fine on both the USB 4 and USB 3.2 ports, but I suspect this is sidestepping the root problem.
  • The external docking station I’m using is a “Cable Matters Inc. Thunderbolt 3 Docking Station”.
  • Here’s the output of boltctl for this device.
 ● Cable Matters Inc. Thunderbolt 3 Docking Station
   ├─ type:          peripheral
   ├─ name:          Thunderbolt 3 Docking Station
   ├─ vendor:        Cable Matters Inc.
   ├─ uuid:          db030000-0080-7d18-2313-a016a2055022
   ├─ dbus path:     /org/freedesktop/bolt/devices/db030000_0080_7d18_2313_a016a2055022
   ├─ generation:    Thunderbolt 3
   ├─ status:        authorized
   │  ├─ domain:     8ab73804-c12a-d9c9-ffff-ffffffffffff
   │  ├─ parent:     8ab73804-c12a-d9c9-ffff-ffffffffffff
   │  ├─ syspath:    /sys/devices/pci0000:00/0000:00:08.3/0000:34:00.6/domain0/0-0/0-2
   │  ├─ rx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  ├─ tx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  └─ authflags:  none
   ├─ authorized:    Wed 21 Sep 2022 12:36:33 AM UTC
   ├─ connected:     Wed 21 Sep 2022 12:36:33 AM UTC
   └─ stored:        Tue 20 Sep 2022 04:06:53 PM UTC
      ├─ policy:     auto
      └─ key:        no