Monitor not being recognized through USB-C port and adapter

Hello,

I am using my new workstation, but I found an issue with the USB-C port and adapter I have here. It’s a simple plug-in, sort of docking station, that has HDMI, USB and what-not ports. When I plug it into my Windows system, I am able to use an external keyboard, mouse and monitor all connected to that, which is in turn connected to the USB-C port of the system.

Now, when I use it on my Fedora station, all works besides the monitor, which is really what I need the most. I tried to look for some ways around this, but they were either for second monitors or quite old, is there something that can help out?

Forgot to mention, for possible help, that currently my Fedora system does not have a GPU and I am using an AMD CPU with iGPU, specifically 7950x3d

It’s possible that your adapter depends on DisplayLink:

Thanks for the reply, I tried to work through those links, but it doesn’t seem to work. When I install openssl it gives me random dots and + signs all over and refuses to do anything else with the 2nd switch code in the 2nd link.