External monitor not detected after a few hours

Using a laptop and the monitor is connected through a USB-C to DisplayPort cable.
Fedora installation up-to-date with the all of the recent updates.
Nvidia drivers were installed from the built-in Software app.

Initially the external monitor was detected and working without problems.
Every time that I boot up after a few hours that my laptop was powered off the external display is not detected anymore, the external display is blank, it doesn’t show up in the display settings and clicking on the display toggle on the keyboard doesn’t do anything.
The laptop’s built-in display works fine.
If I reconnect the USB-C to DisplayPort cable it works again, but the problem re-occurs every day. I don’t want to be reconnecting the cable every day.

Tried a clean reinstall of Fedora, still the same issue.
Tried to switch to Xorg and rebooting, still the same issue.

It isn’t a problem with the monitor or the laptop’s hardware, I didn’t have any issues on Windows 11 on the same laptop with the same monitor.

Also worth noting is that I had the same problem in Pop!_OS, just letting you know. I’m not asking for support for Pop!_OS.

Laptop specs:
Core i7 11800H, 32GB RAM, RTX 3070, 1TB SSD
OS: Fedora 36 Workstation

Has the display gone to sleep, entered power saving mode, or switched its source to another input? These monitor states, especially the last one, may prevent the laptop from detecting the display when it boots up. Ensure the display is awake and still set to the desired input before booting up your laptop next time to see if that enables detection. Let us know what you find out.

Good luck!