Esc key doesn't work

I’m using the Portuguese(Brazil) and my Esc key doesn’t register, I tried different keyboard layouts but didn’t work either. I’m using the Portuguese(Brazil) keyboard layout. On a Samsungbook np550xda.

Are we talking about the built in keyboard?

Does the keyboard have a “cedilha” Çon the keyboard?

It does yeah. Yeah it’s the laptop keyboard.

When you changed to the Portuguese_BR Locale and it not works, it might has a hardware issue.

If your laptop is not brand new, open it and clean first the flat ribbon cable. This connectors are quite tricky sometimes while not making correct contact.

With the command showkey -a pressing ESC, it should give you an output like:
^[ 27 0033 0x1b I also use this layout as you. But my keyboard id a wireless from Logitech.

This is the keyboard
Esc key works fine on Bios.
showkey -a shows nothing.

Pressing FN while pressing ESC gives also no output?
I can not recognize the second symbol on the ESC key. Is it a headphone?

Are you using Gnome desktop? If yes please install gnome-tweaks
Under “Keyboard & Mouse” > “Overview Shortcut” and underneath on the right side there is the button for “Additional Layout Options”

Check there to see if you can find something for your ESC key.

In my case I do switch the decimal coma to dot while using a BR Keyboard (Numeric keypad Delete behavior).

Please also post the output of localectl to see if we miss something there.

1 Like

Holding FN shoes no output either
Nothing about Esc on Tweaks
It’s a headset with a microphone under Esc

System Locale: LANG=en_US.UTF-8
       VC Keymap: br-nativo
      X11 Layout: br
     X11 Variant: nativo

another problem is that pressing the F keys like f2/f3 does the what is supposed to do with the FN key being held.

Try just br should be abnt2 by default.
If i switch to nativo my ESC is dead too.

Select Portuguese (Brasil) just.


That’s what I have already. If I select nativo it completely breaks my keyboard, all the keys get mixed up.

There is something totally wrong …

Try to change in terminal with localectl

Try localectl set-keymap br and check with localectl status

1 Like
   System Locale: LANG=en_US.UTF-8
       VC Keymap: br
      X11 Layout: br
     X11 Variant: nativo

Esc key is still dead.

localectl --help

set-x11-keymap br

Still doesn’t work

Sorry I’m out of ideas.

Where else can I go to get help? It’s kinda difficult to play games without a esc key.

How did you install Fedora 37, with an live ISO?

If you still have a boot iso, please check if there the ESC works.

I really have doubt if it is not a corrosion on the cable or it is not correct connected as the link i gave you on the top.

Se você fala aportuguese pode também perguntar no forum plus(dot)diolinux(dot)com

1 Like

If it works in Bios not means that you should not check what I asked you for.

This was the first my laptop made too when i got problem with the Keyboard. I simply hat tho disconnect it and use an external Keyboard.

But you really could try to clean and check if it is correct in the socket. Sometimes contact cleaning spray helps too.

I’m using a Samsungbook NP550XDA-KF1BR on Fedora Workstation 37. I have tried different keyboard layouts but my Esc key doesn’t register in any of them. The F keys have functions like changing screen brightness or volume as default, instead of only doing those things when the Fn key is pressed. When I installed Fedora the Portuguese (Brazil) layout wasn’t available so I had to choose Brazil, Nativo and it completely broke my keyboard. I couldn’t test the layout during the installation because the area usually available was blocked. When I booted it was a pain in the ass to type my login and password because all the keys were scrambled. When I got in I was able to change the layout, but it wasn’t showing on localectl, so I had to change it on the Terminal. Now localectl shows:

System Locale: LANG=en_US.UTF-8
       VC Keymap: br
      X11 Layout: br

Also When I press F1 it starts spamming this character ±±±±±±
Showkey -a doesn’t show any input when Esc is pressed.
The Esc key works on the Bios so it’s not a hardware problem.
My Page Down Key on the numeric keyboard sometimes appears as “Next” and my keyboard shortcuts for it don’t work anymore and sometimes it appears as “End” like it should


Please do not double post: