Errors during downloading metadata for repo 'amdgpu-proprietary'

Hi there,

I am a complete Linux noob (tried Ubuntu long ago) but recently switched over to Fedora 37 after doing some research. So far, I am absolutely loving the experience with KDE Plasma and will most likely never return to Windows full time. One error I am running into occurs when I try to upgrade or update. It seems like any upgrade/update related to my AMD GPU does not work. Here is the error I receive:

AMDGPU 5.4 Proprietary repository                          238  B/s | 178  B     00:00    
Errors during downloading metadata for repository 'amdgpu-proprietary':
  - Status code: 404 for https://repo.radeon.com/amdgpu/5.4/rhel/9.0/proprietary/x86_64/repodata/repomd.xml

I am using a ASUS Zephyrus G14 (2022) with cpu: 6900HS and gpu: RX 6700S.
One weird thing to note: when I do neofetch It says I have 2 GPUs:
AMD ATI Radeon 680M (integrated graphics)
AMD ATI Radeon RX 6650 XT (dedicated, but this is the WRONG GPU…)

I’m assuming the fact that the dedicated GPU being incorrectly listed there has something to do with it. I’ve tried installing the 6700S AMD driver from their site and followed documentation to install it, but still having the same error. Anyway, any help would be appreciated.

The error from dnf has nothing to do with your hardware. It’s just a 404 “not found” error, meaning that this URL doesn’t exist: https://repo.radeon.com/amdgpu/5.4/rhel/9.0/proprietary/x86_64/repodata/repomd.xml

The directory here is indeed empty: Index of /amdgpu/5.4/rhel/9.0/proprietary/x86_64/

The easiest way to resolve would be to install the latest rpm from AMD that contains the correct repo information.

2 Likes

Justin, thank you so much. I downloaded the correct latest rpm from AMD’s website directly and it worked.

The main difference this time around was that I downloaded and installed the ‘PRO’ version of the Linux_x86 RHEL drivers compared to the regular RHEL drivers in the section above it. Thanks again!

Do you need the AMD proprietary driver? There are open source AMD drivers built into the kernel that many of us use.