Kernel after 6.2.15 don't boot; error with repos in dnf (amdgpu)

Hi, i have the same problem as the other guys without an nvidia gpu and intel cpu. I tried the experimental kernel and normal kernel and they both don’t boot. I tried to sudo dnf upgrade to try and download the newer kernels, but it doesnt even try to download newer kernels (i’m on 6.2.15 rn). I tried to add (if it’s the thing in grub with the ‘e’ command) the ‘module_blacklist=ucsi_acpi’ but it didnt work either. I’m a newbie and i dont know how to do much more after that, did I broke something else thinkering? the upgrade command outputs:

'sudo dnf upgrade
Warning: failed loading '/etc/yum.repos.d/amdgpu-pro.repo', skipping.
AMDGPU 5.4.5 repository                         162  B/s | 178  B     00:01    
Errors during downloading metadata for repository 'amdgpu':
  - Status code: 404 for (IP:
Error: Failed to download metadata for repo 'amdgpu': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Fedora  -  - VirtualBox                         2.5 kB/s | 819  B     00:00    
Fedora  -  - VirtualBox                         3.5 kB/s | 1.7 kB     00:00    
Fedora  -  - VirtualBox                         3.0 kB/s | 819  B     00:00    
Error: Failed to download metadata for repo 'virtualbox': repomd.xml GPG signature verification error: Bad GPG signature
Ignoring repositories: amdgpu, virtualbox
Last metadata expiration check: 0:32:57 ago on mer 14 giu 2023, 16:08:41.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package mesa-va-drivers-freeworld-23.0.2-1.fc38.x86_64
  - nothing provides mesa-filesystem(x86-64) = 23.1.1 needed by mesa-va-drivers-freeworld-23.1.1-1.fc38.x86_64 from rpmfusion-free-updates
 Problem 2: cannot install the best update candidate for package mesa-vdpau-drivers-freeworld-23.0.2-1.fc38.x86_64
  - nothing provides mesa-filesystem(x86-64) = 23.1.1 needed by mesa-vdpau-drivers-freeworld-23.1.1-1.fc38.x86_64 from rpmfusion-free-updates
 Package                      Arch   Version       Repository              Size
Skipping packages with broken dependencies:
 mesa-va-drivers-freeworld    x86_64 23.1.1-1.fc38 rpmfusion-free-updates 3.4 M
 mesa-vdpau-drivers-freeworld x86_64 23.1.1-1.fc38 rpmfusion-free-updates 3.4 M

Transaction Summary
Skip  2 Packages

Nothing to do.

any help? i can run whatever command you want, but i dont know these commands myself.

This seems a failed repo and probably should be disabled for dnf. I don’t think that repo and the amdglu-pro driver are advisable.
dnf repolist will provide the actual repo ID in the first column
sudo dnf config-manager --disable <repo name> will disable the offending repo.

This seems like a problem with the repos not being in sync with version numbers. The “-freeworld” packabes come from rpmfusion and the others come from fedora. It does happen that one may get an update and the other may not match at that time so waiting for the time required for the sync in version numbers usually solves this message.

I have moved this from Fedora hangs on boot after upgrading to kernel 6.3.4 - #79 to a new topic in order to avoid to blur the other one, which already “incorporated” the nvidia issue. Feel free to adjust the tags and title.

Thank you for yout fast response. The command to disable the repo amdgpu outputs this : ’

sudo dnf config-manager --disable amdgpu
[sudo] password for marci: 
Warning: failed loading '/etc/yum.repos.d/amdgpu-pro.repo', skipping.'

it says the same message about the amdgpu pro repos even when trying to disable the virtualbox repo.

What is the actual repo name given with the dnf repolist command. ?

At least for /etc/yum.repos.d/amdgpu-pro.repo it would appear that file may be improperly formatted or have invalid data.

The virtualbox repo seems to have invalid gpg key data.

I’m sorry for not clearing that up, the dnf repolist command outputs:

dnf repolist
Warning: failed loading '/etc/yum.repos.d/amdgpu-pro.repo', skipping.
repo id                                        repo name
amdgpu                                         AMDGPU 5.4.5 repository Copr repo for PyCharm owned by phracek
fedora                                         Fedora 38 - x86_64
fedora-cisco-openh264                          Fedora 38 openh264 (From Cisco) - x86_64
fedora-modular                                 Fedora Modular 38 - x86_64
google-chrome                                  google-chrome
microsoft-edge                                 microsoft-edge
protonvpn-fedora-stable                        ProtonVPN Fedora Stable repository
rocm                                           ROCm 5.4.5 repository
rpmfusion-free                                 RPM Fusion for Fedora 38 - Free
rpmfusion-free-updates                         RPM Fusion for Fedora 38 - Free - Updates
rpmfusion-nonfree-steam                        RPM Fusion for Fedora 38 - Nonfree - Steam
updates                                        Fedora 38 - x86_64 - Updates
updates-modular                                Fedora Modular 38 - x86_64 - Updates
virtualbox                                     Fedora  -  - VirtualBox

I suspect there may be 2 different amdgpu*.repo files on your system.
It complains about the file /etc/yum.repos.d/amdgpu-pro.repo and skips loading it. Then it shows the amdgpu repo.
Since the amdgpu-pro driver is not maintained and use is deprecated I would totally remove that file and eliminate that message

As far as the virtualbox repo, that one seems the VB from oracle and rpmfusion has a copy of VirtualBox that can be installed and is tweaked for use specifically with fedora. It may be advantageous to switch the location used for installing and updating VB should you wish to try that.

Thank you, i removed the amdgpu-pro repo manually from the folder, it doesn’t show the problem anymore, and i can download newer kernels.
The problem with mesa drivers still persists, but its not really a problem since you said it will get fixed soon. I also removed the virtualbox repo altogether since i dont need it anymore (needed for a past project), i will make sure to download it from the right source the next time.
As for the initial problem, i successfully downloaded the 6.3.7 kernel, but it’s stuck in loading. Is there anything more i can do now, other than waiting for a newer kernel?

The 6.3.7 kernel hanging seems it may be a different issue and may need its own topic to address that.

There is a way to bypass the mesa issues. If you do not need the extra features of the mesa-va-drivers-freeworld & mesa-vdpau-drivers-freeworld packages one could simply revert to the fedora versions of those packages. Otherwise it is likely the wait will be fairly short for the rpmfusion and fedora packages to be brought into sync. It seems the fedora versions are at 23.1.2 while the rpmfusion versions are still at 23.1.1

1 Like