Error: Can't pull from untrusted non-gpg verified remote - Flatpak

Error While Installing TubeConverter(Video Downloader) in Fedora 38 KDE Plasma + Gnome.

Error: Can't pull from untrusted non-gpg verified remote

error: Failed to install org.nickvision.tubeconverter: Can't pull from untrusted non-gpg verified remote
  • I Was Installing this of Fedora KDE Plasma + Gnome.
  • My System is Fully Updated.

Please don’t post images with text content – the content can’t be found in searches.
Just paste as text bracked with lines of three backquotes.

This could be just unfortunate timing where something was being updated when you tried the install. If the problem is reproducible, Flathub org.nickvision.tubeconverter has a link to report problems.

Thank You For Your Time and Suggestion.
But I Have Tried it 5 to 10 times in a Span of almost 2 Days.

Did you set the flathub remote to --no-gpg-verify at some point?

What’s the output of:

flatpak remotes -dv
flatpak remotes -dv


F: Opening system flatpak installation at path /var/lib/flatpak
F: Opening user flatpak installation at path /home/praddyumnyadav/.local/share/flatpak
fedora  Fedora Flatpaks oci+  -       -       -       1       system,oci      -       -       -       -
flathub Fedora Flathub Selection    -       -       -       1       system,no-gpg-verify    Selected applications from Flathub    Selected applications from Flathub (

Not sure why it has no-gpg-verify. To fix it (and get rid of the “Fedora Flathub Selection” name at the same time since it’s no longer relevant):

flatpak remote-delete --force flathub
flatpak remote-add flathub

Currently, I Have 6 big apps Installed on my Computer with Flatpak and Flathub and I am from an area Where Internet Connection is Easy to Get But not Very Fast I also have only 2GB of data available for a Day.

Is there any way to do this Without Removing Flathub as a Remote Because if I Try to remove Flathub as a Remote It says that You Have to Remove Every application Installed with Flathub and that’s not the most convenient Methode for me so is there any other way to do the same OtherWise I Will Remove all the apps and Reinstall Flathub on my Computer.

1 Like

Sorry! Add --force to the first command, then it won’t remove your existing apps.

flatpak remote-delete --force flathub
flatpak remote-add flathub

(I was aware of this issue, but forgot to include it while copy-pasting)

Thank You Very Much for Your Time @jn64 It Helped me a Lot.