Epson L575 all-in-one drivers. Can't scan. No updated version available, trying to compile. Help!

I posted it on Reddit about being unable to scan with Epson EcoTank L575 printer and forgot to post here, but the problem persist. (here). I tried reinstalling the packages and even the updated packages, that still do not have a Fedora 33 version, made available after I posted. I downloaded some source to try to compile it, but can’t solve dependencies.

Furthermore, I tested as suggest paid software, VueScan. It is available via Flatpak, but did not work as a flatpak. It worked when I downloaded a “portable” version and ran it with root privileges. VueScan is a paid software, so it is not a solution for my friend.

VueScan has the drive embeded in itself which, for what I can tell from the imagescan-bundle package, is what is done with the Epson drivers for the scanner also.

No concrete advice, but hopefully the more activity, the more hits that you will get. My recent experience is that the whole printer / scanner issue is still a real crap shoot on Linux. Basically any all in one that works with hplip is golden. Everything else, not so much. Even newer printers can sometimes be supported by drivers that haven’t been updated for five to eight years. Research is everything. Good luck.

1 Like