Document or image scanning broken on Silverblue?

I have been messing around trying to get my USB connected scanning hardware (an Epson V370) to work with Silverblue (29/30/31) for some time, with multiple issues and absolutely no luck. Really open to some suggestions as scanning on Silverblue IMHO currently seems like a dead-end which could use some serious lovin.

My preferred approach was to install hardware specific drivers using rpm-ostree and use flatpak’ed apps (like VueScan) and where necessary rpm-ostree installed apps (like simple-scan).

1] The drivers for my brand of scanner fail to install when using rpm-ostree ( I opened a bug a while back) which I have since closed because the error messages given by rpm-ostree seem misleading and so describe the problem incorrectly. When I get time will open a new bug report that better describes the install issue with rpm-ostree.

2] If you do get a scanner driver installed and working in Silverblue, scanning apps can’t “see” the scanner. As part of trying to diagnose the bug mentioned above I manually installed the Epson scanner driver rpm’s. This (mostly) worked and I was able to scan using Epsons’s iScan app.

However, in this environment the flatpak version of VueScan could not recognise that a scanner was installed. Simple-Scan (no-flatpak, installed using rpm-ostree) also could not connect to the scanner. Others may have also seen this issue with HP scanners.

3] Flatpak scanning apps on regular Fedora can’t see an installed USB scanner. When I run the flatpak version of VueScan on regular Fedora with all the drivers installed normally (using dnf) and otherwise working - it cannot see the scanner. I suspect that there are general issues accessing scanner hardware from flatpaks hiding under this rock.

4] The only workaround I have for scanning in Silverblue is to use a toolbox which has the scanning apps and required drivers installed in it. No flatpaks, and using the command line - which to me seems clunky and pointless in a Silverblue context.

I have asked similar questions before and on this forum to see if anyone has scanning working - without response. In addition there are a number of dead or dying discussions on scanning in a containerised Fedora environment around here and here. And more on life support here and here

In my opinion for what its worth it seems to me that that scanning (a least in my case using Epson non-networked scanners) and Silverblue is completely broken (at least until it’s fixed). If Silverblue (or CoreOS, etc for that matter) are ever to become more than a fun place to dabble with containers, we have to address hardware interaction issues like scanning more aggressively.

1 Like

opened bug https://github.com/coreos/rpm-ostree/issues/1925 which hopefully describes the epson scanner driver install issue a bit better.