Enable Secure Boot

Hello, I recently installed Fedora on my laptop. I checked whether the secured boot was disabled or not in a terminal and it showed that it was disabled. I went to the Bios setting to enable it but it was greyed out. I want to enable secure boot as it is essential for kernel security. Is there any method to enable it? Thank you for your time!

Depends on your device model. On my laptop I can’t enable secure boot unless I disable Legacy support (BIOS boot). Maybe it is the same for you?