Duo window doesn't render correctly

I had this issue in >Fedora 32 Beta and it’s still here in Fedora 32 Final.

Launch Duo.
Self Window doesn’t render correctly (see image).

I tried this in all three browsers, and it fails.
I tried this using other versions of Linux, and no issue.

Am I missing a codec or something?


I just tried it out, and it works just fine here in Firefox on Fedora 32. Since you can see the other person’s video, it shouldn’t be a codec related issue.

Can you try creating a fresh user and testing there if the issue persists?

1 Like

Problem found: Video drivers.

The DEFAULT nouveu drivers cause this issue.

When I used the Pop!_OS with Nvidia drivers, it worked fine.

I am test driving OpenSUSE Tumbleweed.
1- using the default config, same exact issue.
2- install the NVIDIA drivers (which is STUPID EASY on OpenSUSE), and it works fine.

So that is the answer… it’s the video drivers.

1 Like

Did the Nvidia drivers not work on Fedora?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.