Dual Monitor does not work on Fedora 37


I have a laptop that I want to use with two external displays.

The laptop is a Clevo with a NVIDIA GeForce RTX™ 3050 Ti Laptop GPU / Mesa Intel® UHD Graphics (TGL GT1) graphics card. I have installed the Nvidia drivers and setup them following some web tutorial.

One display is a 22’ and the other a 32’ display.

When I use the laptop with either one of the displays, it works well, but when I connect the two external displays at the same time (one through HDMI, the other through miniDP), the big one has not output. When I have a look at the settings, the 3 displays appear (the 3rd one being the one integrated to the laptop), but the big one is “disconnected” (cf. screenshot).


The bizarre thing is that when I boot my computer, on the GDM screen, the 3 displays have a good output!

So, how to fix this? Much thanks for the help!

I don’t use that same GUI, so I’m not sure. But the picture makes it look like merely software disabled, not “disconnected”. Does that control not work to enable it?

Assuming it doesn’t work:

Some of the closed source Nvidia drivers don’t work with Wayland. Are you using Wayland? Have you tried selecting X11 instead of Wayland when logging in?

Do you need the closed source Nvidia drivers? For a long time I used them because my obsolete display card caused the nouveau driver to crash. It certainly did in Fedora 35. But when I upgraded and initially had a lot of trouble getting the closed source drivers to work, I noticed that the reproducible crashes in nouveau had finally gone away. I switched soon after that to a new AMD display card, so I didn’t do enough nouveau testing to be sure.

I understand most people choosing the closed source divers have other reasons (even though nouveau doesn’t crash for them). Probably in some uses those other reasons are valid. But often it seems to be just a generic “it’s supposed to be better” when it actually isn’t worth the trouble.

He absolutely does.
Nouveau does not presently support the 3050 or similar newer GPUs.
Also, nouveau does not support hardware graphics acceleration on any nvidia GPU.

The suggestion to try with xorg instead of wayland is very good. Several things in wayland still are not fully compatible with nvidia.

That screenshot shows the monitor turned off, but it may be disabled and not able to turn on if the DE (wayland) prevents using it.

I’m using X11, as Wayland did not permit me to share my screen properly last time I checked.

@computersavvy thanks for the insight, I did not know I really had to use them over nouveau.

On the screenshot, I obviously tried to toggle the button, but it returns to its previous disabled state quickly afterwards.

Often /var/log/Xorg.0.log will show the reason for such a problem (note the single capital letter if you type, rather than copy/paste that name). It is a big file with confusing contents. Having the answer in there doesn’t mean it is easy to find. But it might not be too difficult.