Dual boot system: Can no longer boot into Win 10

I have a refurbished Dell Latitude e6330 laptop on which was installed Win 10. I added dual boot with Fedora months ago (pre-F35). The laptop and dual boot worked fine for months. Along the way I updated to F35. Still it operated fine.

Just yesterday I experienced a setup error upon booting (seemingly the CMOS battery - which I fixed by replacing). At this point the laptop would only try to go to Windows and issued a “Invalid partition table” error.

I got into the BIOS and found I had lost the UEFI selection and with it the GRUB/dualboot menu. I selected UEFI and now the GRUB menu appears at boot.

However, if I select Windows from the GRUB menu, I get: Diagnosing your PC, followed by:
Automatic Repair which don’t really offer any help.

Sometimes I get Your device ran into a problem and needs to restart

Any advice? Did I lose some other BIOS setting when the CMOS died?


When you say dual boot, do you mean that you have Windows and Fedora stored on the same drive? Or are each on a separate drive?

Same drive.

Since you already on UEFI mode, could you check the current boot order in BIOS and change it to make the Windows OS become your first order? After that, save and boot to your Windows OS (it will directly booting without presenting grub menu) and do the repair.

I’ve done that but I don’t how to proceed with “Repair” - the options presented don’t seem to offer any help.

I get this:
Diagnosing your PC , followed by:
Automatic Repair which don’t really offer any help.

Maybe you could check this dell docs about recovering the Windows UEFI boot.

Thanks so far.

Following the Windows 10 " If you do not have the Installation Media:" section,

It asks me to “Verify that the EFI partition (EPS) is using the FAT32 file system”

I have no way to know what the so-called EFI partition is since none of the three are identified as such. This is what I get from list vol

Volume 0    D                  DVD-ROM          0 B   No Media
Volume 1    C       NTFS       Partition      70 GB   Healthy
Volume 2            FAT32      Partition     600 MB   Healthy

I guessed that the unlabeled Volume 2 was the target of the steps so labeled it as ‘E’

But the rest of the steps are problematic. To wit… AFTER a bunch of steps Microsoft says “But wait” How ridiculous.

Note : If your Operating System media is Windows 10 (version 1709 or newer) use the following command instead of the last set of steps:

  • c:\Windows /s <boot letter>: /f UEFI

That command doesn’t work.
'c:\Windows' is not recognized as an internal or external command

Any ideas?


Oh huh,

c:\Windows /s <boot letter>: /f UEFI

at first glance doesn’t seem like a valid command, so I would ignore that note.

Yes, I believe that the FAT32 partition with a size of 600 Mb is the EFI partition since that partition is typically somewhere around that size.

I would encourage you to reread the instructions under “If you do not have Windows installation media” (as in a USB flash drive or DVD that can be used to install Windows 10). If you are not using any installation media, you can ignore the notes that say "If your Operating System media is Windows 10 (version 1709 or newer) " as it doesn’t pertain to you.

For a very general overview:

  • The instructions want you to boot to a recovery environment where you can run commands in Command Prompt which will allow you to try a potential fix to Windows not booting.
  • The instructions are for a recovery environment since you can’t boot into Windows.

Hope all this helps

I really appreciate all the followups.

I’ll ignore the notes as you say.

But as I wrote, I cannot move past part two of the “next step”:

The next step is the same across all the operating systems:

  1. Rebuild the BCD store.
  2. First run the command below to back up the old BCD: ren BCD BCD.old
    2. Now re-create it using this command: bcdboot c:\Windows /l en-us /s <boot letter>: All

The step in bold is bogus as you seem to confirm.
So what do I do? Just not enter that?

I’ve effectively done that (since it doesn’t work) and I still don’t have a bootable Windows.

bcdboot c:\Windows /l en-us and then bcdboot c:\Windows /s <driveletteryouassign>: /f UEFI

Make sure you already in directory <driveletteryouassign>:\EFI\Microsoft\Boot

Perhaps I should have been more specific, the command in the blue box starting with “C:\Windows” was bogus, this command: “bcdboot c:\Windows /l en-us /s : All” is valid (at first glance). Or yeah, the commands the guy above me posted probably work.

I’ve run the commands as best I can interpret but it still won’t boot Windows.

So I enter the command prompt again, but the label E that I set did not stick.
Should that survive reboot?

Also, I missed this before - “Volume 2”, that I’m setting to ‘E’ is also listed as “Hidden” - should it be?

It should be temporary and we need set it again each time we need to repair the bcd.

Btw, when you in <driveletteryouassign>:\EFI\Microsoft\Boot and run dir, can you find bootmgfw.efi and any other files?

Btw, when you in <driveletteryouassign>:\EFI\Microsoft\Boot and run dir , can you find bootmgfw.efi and any other files?

Yes, that file and many dll and other files plus many directories are there.

I do exactly that - using ‘e’ instead of ‘f’ for the drive letter, exiting and Windows errors out. I get a blue “Recovery” screen with error code #c0000001 and some instructions to use a recovery / installation media (which I don’t have ATM)

Most likely your problem beyond bcd things. You should consider to download the installation media and do recovery from there.

Will my Fedora Linux installation survive using an ISO in the repair process?

Should be survive. You just change the boot order in the bios. That the beauty of UEFI system.

But if something wrong with your Fedora after Windows recovery, it’s relatively easy to fix that.

Btw, I delete my pictures above since you already did the same steps.


Argh, turn out no use to delete my comment above since we still can see it by clicking the history (pencil icon). :laughing:

With a newly created ISO disk, I somehow managed to get Windows working again.

However after choosing the one Windows item in the GRUB menu, I get a choice of two “Windows 10”. Only the top one, that mentions “volume 6” is real AFAIK - it loads, runs etc. The bottom one simply sends me back to GRUB.

How to I get rid of the useless one? I managed to “hide” it in the Control Panel… System settings by unchecking boot delay, but is there a better way?

You could try Win+R then type msconfig then enter. On boot tab, there should show two boot list. Delete one of them. But please becareful.