Drag and drop from nautilus to browsers is not working

When I try to drag and drop files from nautilus to either Firefox or Chrome, the operation fails differently for each one:

Firefox: If I drag a single file to, let’s say, Gmail’s compose window, or Whatsapp, it works as expected; however, if I drag multiple files, only the first one is recognized, as if it were the only one selected. Subsequently dragging other files one by one works

Chrome: Drag and drop fails every time – it’s as if the browser is not recognized as a valid drop container, the files are “returned” to nautilus (there is a UI animation of them returning to the file manager window from where they were dragged). This happens both if I drag single or multiple files.

This used to work until recently, can’t really precise when it broke.

Anyone else experiencing this as well?

  1. dnf upgrade
  2. Try as newly created "test-user"
  3. Try reinstall the "integration packages" (gnome-shell-integration, or such. dnf search ... may help)
  4. Perform the drag'n'drop. See the journalctl -xe | tail (if it works, or similar).
  5. Until it gets fixed, consider to install KDE. After commiting all the bug reports and tests, there should be at least one place to fall-back. Then, when KDE will got this feature broken... there is Gnome with hopefully working feature. MATE may be an option, etc...

If you can reproduce this in a new user, it would be worth reporting to the workstation working group. It sounds like a general issue but it could be in a number of places. So, a developer will have to weigh in.

I know I can’t use drag/drop in Qutebrowser, but that’s probably because it’s a Qt app on Gnome. Chrome may be similar. I think firefox is GTK, so that maybe why single dropping works there, at least.

Thanks both @FranciscoD and @vits95 for your comments.

I set up a new, fresh account, and drag & drop worked both on Firefox and Chrome. I then did the tests again on my account and… it also worked! So, some of the last updates must have fixed the problem, whatever it was. I will still test again on my computer at work (also running F31), but I can’t see why it would not work.

1 Like