Does NVIDIA work on Silverblue 30?

so i just booted on Sb29, and voila :))

till few days ago, trying rebasing on 30 wasnt working, so is that now fixed? and most importantly can we use @alexl NVIDIA driver on Sb 30??

so i asked @otaylor and there isn’t yet a working tree for 30 :frowning:

it works

sudo rpm-ostree install
replace 29 with 30, thats all you have to do

1 Like

did they fix the rebasing on 30?!??!

Yeah, 30 has an OSTree branch now.

1 Like

ookay! i will make you babydora admin now! first b/c you push everyone away to other blogs (i saw that! ha!), and 2nd b/c you didnt share that already!! you totally deserve it :stuck_out_tongue:

is there a way to enable wayland on silverblue using the nvidia driver? its sadly not possible to edit /usr/lib/udev/rules.d/61-gdm.rules, because of the read only filesystem. is there maybe another way to get it work?

i think you can do smth like ostree admin unlock and temporary edit it; but it is not that NVIDIA works w Wayland anyway. already tried it on F30/GNOME 3.32

i see thanks…

i wanted to try it because, i notice many slowdowns when the nvidia driver is installed.

for example if i run a video in kodi, dragging a window on the desktop feels like very low fps… same when retroarch is running or a video in chromium is playing.

otherwise it seems fine, i remember having this problem the whole time, even without running a video, but its still annoying.

on nouveau i dont notice this problems.

i will update today to see, but on F30 that everything should be identical everything is super fast w NVIDIA, and same with Sb29 i have

Is anyone else having problems with NVidia on GNOME 3.32? I am seeing some real janky behavior, periodic screen freezes and just general usability problems with 3.32 that weren’t there with 3.30. I had to blacklist the module and stick with the Intel graphics to get things usable. Cinnamon looks better - I didn’t spend too much time in it before disabling the modules, though.

on Fedora 30 all is perfect but i had to used the RPM-Fusion driver and not the one from Fedora Repo (which is again hosted on RPM-Fusion but it is different), now im rebasing Silverblue 30 to try what @fishxz said

ok! i just installed a fresh Sb30 w NVIDIA, and i can verify performance is bad :frowning:
driver is 418.43 from @alexl

I didn’t see anything in the Arch forums about this - dash to dock and dash to panel are broken but dash to dock works if you install it from the github repo.

so, you say its fine on fedora 30 but bad on sb 30? :confused:

what are the problems you noticed? have u tried any of the cases i outlined before?

i didnt try your cases, i even have lag on Shell overview animation, while my Fedora 30 flies!!

i just tried fedora 30 and i noticed the same problems there, but i was able to test wayland… on wayland everything is smooth and none of the problems happened… sadly gaming suffer from bad performance (cause of xwayland?)

yeah, not acceleration on XWayland; btw it makes me huge impression your NVIDIA experience; i have totally different outcome! all super on Xorg, a disaster on Wayland; im with NV1060, whats your card? btw i use the RPM-Fusion driver and not the one from GS Repo

i tested on my second pc with a gtx760. i also used the driver from rpm fusion.

my main pc has a 1060, but both systems behave exactly the same.

the performance problem is nothing new to me, i give linux (or should i say gnome :slight_smile: ) from time to time a try since years and its always the same: nouveau/wayland fine… nvidia/x11 slowdows

it had, just had to go there :upside_down_face::upside_down_face::upside_down_face::upside_down_face::sweat_smile: