DNS/Networking Issues After Upgrading to F33

Prerequisites courtesy:

I upgraded from F32->F33 last night (Cinnamon DE), and now various system apps are having trouble with internet connectivity.

  • I am no longer able to connect to my VPN provider via the Network Manager. The VPN Type is a pre-made OVPN file. When I turn it on, it just stalls at “Connecting”.*
  • I cannot check for updates, neither via Gnome Software nor dnf update. The former just spins during “Refreshing”, the latter gets stuck at 0% on the progress bar that displays while checking the various repos. It never times out, however, and I have to break out of it via Ctrl+C or Ctrl+\ to make it stop.
  • Firefox will not load any page. Again, it does not throw an error like it would if I tried opening a page with WiFi off, it simply stalls infinitely while trying to do the domain lookup.

Not all programs are having this problem. HexChat, Thunderbird, and even Falkon seem to work fine, and on Falkon I can load the same URLs that Firefox is failing to load. I was able to get Firefox to work agains by enabling DNS over HTTPS in the settings, which is just throwing the effort onto a third-party provider, from what I understand; so it’s not really a permanent fix.

Troubleshooting So Far

*Here is what I see regarding the VPN when I try to connect and then run journalctl -r:
Jan 17 13:16:53 malebolge nm-openvpn[19190]: RESOLVE: Cannot resolve host address: VPNDOMAIN.com: (Name or service not known)

Supporting Info

systemd-resolvd is running:

[admin@malebolge ~]$ systemctl status systemd-resolved.service 
● systemd-resolved.service - Network Name Resolution
     Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-01-16 22:59:33 EST; 15h ago
       Docs: man:systemd-resolved.service(8)
   Main PID: 1259 (systemd-resolve)
     Status: "Processing requests..."
      Tasks: 1 (limit: 9375)
     Memory: 15.3M
        CPU: 2.004s
     CGroup: /system.slice/systemd-resolved.service
             └─1259 /usr/lib/systemd/systemd-resolved

Jan 16 22:59:33 malebolge systemd[1]: Starting Network Name Resolution...
Jan 16 22:59:33 malebolge systemd-resolved[1259]: Positive Trust Anchors:
Jan 16 22:59:33 malebolge systemd-resolved[1259]: . IN DS 20326 8 2 e06d44b80b8f1d39a95c0b0d7c65d08458e880409bbc683457104237c7f8ec8d
Jan 16 22:59:33 malebolge systemd-resolved[1259]: Negative trust anchors: 10.in-addr.arpa 16.172.in-addr.arpa 17.172.in-addr.arpa 18.172.in-addr.arpa 19.172.in-addr.arpa 20.172.in-addr.arpa 21.172.in-addr.arpa 22.172.in-addr.arpa 23.172.>
Jan 16 22:59:33 malebolge systemd-resolved[1259]: Using system hostname 'malebolge'.
Jan 16 22:59:33 malebolge systemd[1]: Started Network Name Resolution.

resolvectl seems to be able to query:

[admin@malebolge ~]$ resolvectl query fedoraproject.org
fedoraproject.org: 2605:bc80:3010:600:dead:beef:cafe:fed9 -- link: wlp2s0
                   2605:bc80:3010:600:dead:beef:cafe:feda -- link: wlp2s0
                   2604:1580:fe00:0:dead:beef:cafe:fed1 -- link: wlp2s0
                   2620:52:3:1:dead:beef:cafe:fed6 -- link: wlp2s0
                   2610:28:3090:3001:dead:beef:cafe:fed3 -- link: wlp2s0
                   2620:52:3:1:dead:beef:cafe:fed7 -- link: wlp2s0
                      -- link: wlp2s0
                       -- link: wlp2s0
                       -- link: wlp2s0
                         -- link: wlp2s0
                         -- link: wlp2s0
                        -- link: wlp2s0
                      -- link: wlp2s0
                        -- link: wlp2s0
                           -- link: wlp2s0
                           -- link: wlp2s0

-- Information acquired via protocol DNS in 15.7ms.
-- Data is authenticated: no

[admin@malebolge ~]$ resolvectl dns
Link 2 (wlp2s0): is the correct IP to hit my router.

[admin@malebolge ~]$ resolvectl domain
Link 2 (wlp2s0): ~.

I can’t tell from the above command if I’m literally supposed to put “domain” in there or substitute a domain, e.g. fedoraproject.org?

Finally, resolve.conf looks correct for systemd-resolve (based on my googling, anyway):

[admin@malebolge ~]$ ls -l /etc/resolv.conf
lrwxrwxrwx. 1 root root 39 Jan 16 22:00 /etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf

[admin@malebolge ~]$ tail /etc/resolv.conf
# Third party programs should typically not access this file directly, but only
# through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
# different way, replace this symlink by a static file or a different symlink.
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

options edns0 trust-ad

With a working browser and e-mail client, I can still get work done, but I still want to get this resolved as soon as possible, as it would be hazardous if I am unable to update my system any further. I’m looking for further troubleshooting advice. I don’t know enough about DNF to be able to post relevant logs here to demonstrate the updating problem, but I’ll follow any commands provided.

Thank-you in advance!

1 Like

Try to disable automatic DNS and specify a major public DNS provider instead.

Where would you suggest I set that?

I have an option in Cinnamon DE’s Network config to set it on the connection settings to my home WiFi network, but that didn’t seem to make a difference.

Are you suggesting I add it to the /etc/systemd/resolved.conf instead?


That fixed all three! Amazing!

But how can I verify which DNS servers it is using now?

1 Like

Please use a bit the spyglass to find similar problems as you have … so you learn a lot.
I found this:

" https://fedoraproject.org/wiki/Changes/systemd-resolved "

resolvectl --no-pager status

See the link which includes “DNS Domain” ~. as the default resolver route.
The system should use “Current DNS Server” as round-robin of “DNS Servers” on that link.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.