Disk Write Error in Steam

I cannot download game in steam on fedora 37. It keep on saying “Disk Write error”.
By default steam downloads to the path /home/deepanshuarya/.var/app/com.valvesoftware.Steam/.local/share/Steam/steamapps
which has enough space for game.
I also tried to use my other partition(windows) but still face same error. But this time i observed something strange. when using other partition it uses the path /run/user/1000/doc/7104bc7d/steam_library/steamapps.
out if this i changed permission of every folder except doc. i cannot change permission for same even after using sudo.


so kindly help me for the same.

This path seems foreign to me.
I installed steam from rpmfusion and it installed everything under the /home/USER/.local/share/Steam/ folder. The /run tree is a volatile tempfs file system that is created at boot and destroyed with every shutdown or restart so changing things there would be at best temporary and pointless. This is shown with the mount command.
tmpfs on /run type tmpfs (rw,nosuid,nodev,seclabel,size=6554592k,nr_inodes=819200,mode=755,inode64)

My question for you to consider is “how did you install steam?” If it was installed from rpmfusion then maintenance and structure is standard and many of us who use steam are able to assist. If it was installed from another source then it may not be installed in the standard paths and structure used by fedora so our support may not be as simple.

Another factor to consider is SELinux. If you have selinux in enforcing mode and the context is not proper then that can prevent access and usage as well.

It’s installed via fedora flathub Selection

This path is from the xdg-desktop portal that is used by Flatpaks.

If you want to grant access to other folders on your system to the Steam Flatpak then you need to add them to the list of authorized folders for the Steam Flatpak using Flatseal for example, otherwise Steam won’t really have permanent access to them.

please tell how to do that.

Are you adverse to using the rpm version from rpmfusion?
If not then the issue you see may easily be overcome by simply removing the flatpak and installing steam as rpm. I have been using steam as installed from rpmfusion for several years and never had an issue with it.

Once the rpmfusion-nonfree-steam repo is enabled then steam is installed with dnf install steam and launched by the icon in the activities menu. It also automatically updates if needed every time launched.

Install Flatseal and add a Filesystem path: https://github.com/tchx84/Flatseal/blob/master/DOCUMENTATION.md#filesystem

1 Like