Disable Secure Boot to install Silverblue?

I’ve been away from Silverblue for a while but I’m going to try it again when I get my new ThinkPad next week. Do I need to disable Secure Boot to install Silverblue? I’ve forgotten…

1 Like

No — it uses our signed boot path. It should just work.

1 Like

I just reinstalled Silverblue on a new ThinkPad. The USB installer would not boot with Secure Boot enabled. I disabled Secure Boot and everything went fine. Just FYI.

What model was it?

ThinkPad X1 Carbon Gen 10.

That’s concerning. I’ll check with Lenovo.

Hi - I think you need to enable the 3rd party certificate in the BIOS. You can do this from the BIOS setup screen (F1 during early boot).

Details here if interested: https://download.lenovo.com/pccbbs/mobiles_pdf/Enable_Secure_Boot_for_Linux_Secured-core_PCs.pdf


I’ve got Silverblue installed and its running just fine. If I make changes to the BIOS now, will I have to re-install and start all over?

And BTW, since you work for Lenovo I thought you’d like to know that the X1 Carbon is awesome! I got the one with the 2.8K OLED display and it looks fantastic. Its only been out of the box for a day or so but I really like it. Fantastic quality laptop.


You shouldn’t need to re-install - it just means secure boot is enabled and should boot normally.

I hate to ask but if you got the system with the 2.8k OLED doesn’t that mean you have the MIPI camera (aka ‘computer vision’) that doesn’t work under Linux? Just wanted to make sure you were aware in case you haven’t tried the camera yet (We do block that config with our Fedora preload because of it not being supported)
Intel are working on it but it’s very slow going :frowning:

1 Like

I haven’t tried the camera yet. I didn’t know it didn’t work, but honestly, the OLED display is more important to me than the camera. But hopefully it will be supported in future updates.

I did enable Secure Boot according to the directions you provided and it works just fine. No re-install needed.

Now I’m waiting for my ThinkPhone!

1 Like

Tried the camera again on my ThinkPad today. Still not supported. I’ve contacted Lenovo support but they have no information.

Yeah - MIPI camera (which is what you have) is still being worked on by Intel and it’s slooooow.
We’re pushing them to get the driver upstream - the process is started but I don’t know how long it will take.
Once that is done there are pieces needed in user space. There is a workaround of using the V4l2_loopback and some patches in gstreamer that is the current proposal from Intel - unfortunately I just couldn’t get that to work in Fedora. I know a couple of the RH engineers are looking at alternatives.

Thanks for the update.

Secure boot is a security feature in EFI for x86 processors, Red Hat has a Microsoft EFI signature going down to Fedora, Silverblue is only a container based distribution option, nothing more …