Davinci Resolve seriously broken on AMD Ryzen 3400G ( Vega 11 ) with proper drivers!

I have an AMD Ryzen 3400G processor on which i just use the integrated Vega 11 graphics with default stock amd drivers that come preinstalled.

After installing rocm-opencl, resolve opens up and i can navigate through the interface but when i try to do anything, it breaks and freezes and sometimes even if it works then i get no preview. Specially, in the fusion tab whenever i create a text+ node or do some things, it is bound to become unresponsive and freeze entirely. This behaviour is common in all the distros i tested on and also Fedora 40, 39 & 37 and i have also tested on arch based, debian and fedora based distros. The problem is common in all.

Below, I have linked a video explaining the issue :

Please consider helping me !

Please be polite and respectful of all members here. You joined 4 hours ago and are threatening to switch back to windows as if we would really have a vested interest in keeping you on linux.

Since you claim to have tried arch , debian, and fedora (37, 39, & 40) and this is the first time you have even bothered to post on the forum I would suggest that you read these and provide the detailed information as suggested.

You will find that members here are friendly and go out of their way (volunteering) to assist others. If you choose to solve your problems we can make suggestions, but my first reaction to a threat is to say goodbye.

Your linked video is enough of a security risk that I refuse to open it.

1 Like

I’m really sorry for the inconvenience I may have caused, this is my first time actually making a mistake as I am new here and this is my 1st long forum post that I have done in my life. I apologize to everyone who may not have liked the way I conveyed my message.

But still so, please consider helping and i just meant that its a Linux fault somewhere and it was working fine on windows.

Regarding the video, its nothing and I was bound to make it that way and I knew that some suspicions would be raised, because normal video sharing sites messed up my video. I promise its nothing fishy.

I don’t think integrated amd CPU are supported with rocm-opencl. I’m also skeptical that they can provide a significant performance gain, even in windows. I’ve tested the 5600G with darktable opencl on windows and I did not notice a significant improvement.

But people have actually managed to run Davinci perfect in their Linux machines with Amd APUs.

I have updated the link now with a youtube one, so now I think it should not be a security risk :slight_smile: . So now I think you can shorten up your previous response just for convenience and consider looking into my problem and I’m sorry again for being negative in my previous message.

The Arch wiki mostly applies to Fedora:
DaVinci Resolve - ArchWiki

There are multiple caveats and potential problems, so I’m afraid that expecting it to run perfectly would be wishful thinking.

Keep in mind that DaVinci Resolve is a third-party app that is not part of Fedora, so you should lower your expectations even further.

To be honest, this kind of issue is beyond the scope of Fedora devs, and the proper way to deal with it requires to contact the app devs and follow their instructions.

If your work actually depends on it, you should strongly consider using dual boot or whatever is the officially recommended way to run the app.

i also recommend to go https://forum.blackmagicdesign.com/ and ask there help they might have much better solutions for the issue, but remember that DaVinci is still only supported for CentOS/Rocky Linux atm and amd cards needs to have boths OpenGL and OpenCL packages installed and it is recommended that use Nvidia still, but that dosent say dont use amd

also did you check DaVinci Resolve Capture Logs what it says there for errors cause of problems you are having

Here are my Davinci Resolve capture logs :-

From Help > Create Diagnostics Log on Desktop :

From Application Launcher > Davinci Resolve Capture Logs :

Many of us will not use MediaFire because it wants to install cookies on our systems. You should not expect others to wade through long logs to find the important entries.

Cloudwards.net review:

  • MediaFire is an easy-to-use cloud storage service.
  • It lacks strong security measures for your files.
  • Similar cloud storage services offer better features and security.

You should review the logs and extract short sections related to your issue, then post as pre-formatted text (using the </> button from the top line of the text entry panel).

1 Like

We are glad to help!
My comment was because of the tone used in your post and a reminder to be respectful.

Remember we are all volunteers offering assistance as we are able, and you need to provide enough information so assistance can be meaningful.

It has been mentioned many times through the years that a short text post that is relevant to the time and app causing the problem is preferred. External links are discouraged for many reasons, only one of which is mentioned by George just above.

1 Like

Thank you so very much !

The List on supported ROCm devices might exclude your intergrated graphics. This is the first sign of trouble.

Never the less, if you are considering trying We have in the past recommended :

Going to give you a heads up here. . . Since this is typically unknown information :

Your Vega 11 is GFX9 gfx902 / gfx903 ROCm does not support this series, so here is the Supported ROCm Discrete Cards :



There was a way some months back to build everything you need, but that was for a different usecase and no longer available as AMD has removed critical parts of the tooling from their sites.

  • Well, thank you for the information.

  • I have already tried davincibox and the same problem persists

  • But the thing is that my integrated gpu works fine when doing gaming with proton or any other thing related to that and it is only failing in this task, is they the same or very different ?

  • I am just curious and i really want to know from where you got the info.

And I already got schooled by a member before for which i deeply apologized for and it is also my first time on the forum :cry: . So, you could thank him personally for that and so no need to mention it directly in the message :frowning_face: .

Gaming is not Video Editing. Especially on AMD. ROCm is used a lot in the Video editing workloads when available, and Gaming does not require much, if any help from ROCm libs that I am aware of.

From the AMD support page. This is not my first time trying to get ROCm working on gfx10/9/8, Also, if you look around on the forums I’ve instructed some people on how to build the Old versions to force a gfx 10/9/8 to build and run some things. It’s no longer feasible.

https://rocm.docs.amd.com/en/docs-5.7.0/release/gpu_os_support.html

Btw: ROCm 5.7 is the last version to “semi” support gfx/10/9/8 with varying results, as even some MI Instinct cards are not supported.

Here is the latest Docs where they explain that Support for the last gfx90x card will be removed in a future release :


The issue is, We are Volunteers. :fedora: You can’t come to the forums and make demands for software that is barely supported and attempt to hold it over our heads that “You’ll go back to Windows” as if that were a thing that would sway us in some way. :fedora: is free to use, and freedom respecting.

To end, I’ll be honest. If Windows is your solution, then so be it. You have to be pragmatic abou it. Some things just work there and are made that way for reasons.

1 Like
  • Thanks for the clarification !

I think its time for this thread to conclude and thanks everyone that helped .

And hell naw im not turning my back on linux for this one issue, ill just try to use VFIO and do gpu passthrough and if not possible, my last resort would be to dual boot !