Corrupted fonts and icons

I recently installed Fedora 33 and have a strange issue: some letters in system menus are kind of ‘corrupted’ or gliched. Latest updates are installed. Don’t even know where to start digging on the problem.
Looks like the problem letters are ‘S’, ‘t’, ‘y’. This is happening only with system fonts and labels - text in all applications is ok.
Same thing is happening to some of the icons in tray (seen it only once) and the whole background at lockscreen is glitched texture.

How it looks


System info:
CPU: Intel® Core™ i5 CPU M 450 @ 2.40GHz × 4
Memory: 7.4Gb
Graphics: AMD® Redwood / llvmpipe (LLVM 11.0.0, 128 bits) Radeon HD 5650
OS: Fedora 33 (Workstation Edition) 64-bit
GNOME: 3.38.2 Wayland


The problem was solved with GNOME tweak tool (could be found in Software).
Just changed default font to something more comfortable and glitches were gone.
BTW, when I set default font back - no glitches appeared neither in fonts nor lock screen. I think there was some kind of error when system initially loaded fonts.

1 Like

Hmm, after restart some letters now have glitches again. Now it is not the default font (I had URW Gothic Book), so my theory is that fonts are corrupted on system load. Corruptions are gone when I change font in tweak tool. Will do some testing in near future.

The problem is most likely related to mesa/video drivers and/or kernel.
Possible solutions/workarounds:

  • Try Xorg session instead of Wayland.
  • Use integrated video if any, and disable discrete video in BIOS/EFI if required.
  • Try to downgrade the kernel.
  • Install proprietary video drivers if any.

So far Xorg solved the issue, thanks. At least I haven’t seen any glitches for a day.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.