CoreOS Ignition file location - Cockpit VM Installation

Hi guys,

I am coming back to Fedora after a very long break and have a lot of catching up to do. Not quite a newbie, but close enough.

Anyway, I created a VM CoreOS instance through Cockpit (hosted on Fedora Server 38), but I am struggling to find details on where the ignition file needs to reside in this setup. When CoreOS boots, it is looking for an Ignition file, but I’m not clear where that would need to reside to be accessible during the initial boot.

I still have to create an Ignition file, but once created, where does that need to sit to be accessible?

The CoreOS iso is in /var/lib/libvirt/boot and the qcow2 in /var/lib/libvirt/images.

Cheers, Innes (NZ)

I honestly am not really sure (haven’t done a VM installation through cockpit before), but our docs show you exactly what to do using either libvirt or plain qemu, which might help you along your way. In both of those cases you are booting a qcow2 disk image (you don’t need to start from the ISO).

Hey Dusty, thanks for the reply. Apparently, Cockpit will recognise VMs created via libvirt or qemu, so that’s what I’ll try. I’ll post back once I’ve tried that route. Cheers, Innes

It’s probably easiest to do it via the virt-install commands from the Fedora CoreOS docs as Dusty suggested.

If you want to do it purely via the Cockpit UI, you’ll likely have to upload your Ignition config file somewhere on the server beforehand, and then use the “Create and edit” button to add the additional XML bits needed to reference the Ignition config via the QEMU command line argument --qemu-commandline="-fw_cfg name=opt/com.coreos/config,file=..." (libvirt: QEMU command-line passthrough).

Hi Dusty, happy to report that I managed to stand up a CoreOS VM using virt-install with an associated Ignition file and which then appeared in Cockpit automatically. Happy days.

Thanks for your help. I didn’t realise I’d get someone so close to CoreOS reaching out, but after watching the discussion with Mark Pusey from Columbia, I found out your connection. My last experience with Linux was RHEL 3/4 when I built a virtual prod environment on top of VMWare ESX. How things have improved.

Cheers, Innes

1 Like

Hey Timothée,

Dusty’s suggested worked fine, but I’ll try the Cockpit UI method. I was sure there had to be a solution, I just wasn’t looking in the right place.

Thanks for the approach that was specific to my original issue.

Cheers, Innes