Continious update and reboot (Onyx) via an update provided by the software store

I have installed a fresh copy of Fedora Onyx (SilverBlue but with Budgie desktop). I have performed via the command line the usual “sudo rpm-ostree upgrade” and at the moment it says there are no available upgrades.

However, the “Software” store (as it were) says there are. It provides me the option to restart and update (see screenshot). I have repeated this process numiours times with the same two (2) updates. I have used both the app to reboot and I have also tried using “sudo systemctl reboot” via the command line. The outcome is the same with the same two (2) updates listed in the “Software” store.

Can anyone please enlighten me?

And have you clicked the refresh button in the upper left (it refreshes the package meta data).

And have you clicked the refresh button in the upper left (it refreshes the package meta data).

Yes, each time after rebooting. I clicked on the nice circle arrow icon in the lop left to refresh the “Store” and each time, it informs me I have these two (2) updates I can apply. I then click on the big blue button that reads “Restart & Update” which causes the system to reboot. Upon reboot, I against repeat the process.

After boot up, give the system some time to finish updating the metadata for the repo’s and instead of using software, use the command line to check with rpm-ostree … rpm-ostree status to make sure it’s not busy. Once it comes back not busy, try rpm-ostree update again. If software thinks an update is needed and rpm-ostree doesn’t when one is system updates, that would be an issue.

  • Status: Idle
  • No upgrades available.

Same two (2) updates displayed in the “Software” store.

In a terminal type the following … rpm-ostree cleanup -m then rpm-ostree refresh-md this should help.

  • rpm-ostree cleanup -m
  • rpm-ostree refresh-md


  • rpm-ostree status

Result was Idle

  • rpm-ostree upgrade

Reported nothing to upgrade

Opened the “Software” store and saw nothing listed. Checked for updates, found the same two (2). Performed the same “restart and update”

Nothing has changed. Those two (2) updates still are there.

Then I would say Gnome Software has an issue. Perhaps you should file one with them upstream, I’m sure they would be receptive. It may already exist there at Issues · GNOME / gnome-software · GitLab

Time to format C:\

The Fedora Onyx 39 Beta did not have an issue, but the stable version seems to have an issue.

I should have re-installed the Beta and upgraded to the stable as I did previously. I have 2 identical systems (hardware and OS). The issue seems to have been introduced in the final.

I can further confirm this, since that’s just what I did with the other system. It worked.

There are currently no updates available for Onyx. See:

Hopefully this is resolved soon.