Gnome Software stuck

I’m on Fedora Linux 36.20220812.0 (Silverblue)

Gnome software shows 3 updates to be done

I did them several times but everytome they’re back as if I hadn’t done them

I tried with sudo rpm-ostree update
and rebooted but that didn’t help

I’d attach an image but “an error” occurred

1 Like

Could it be related to this issue?


You can try rpm-ostree status to see if you get the error of “Failed to finalize previous deployment”, if so the solution mentioned there will fix your issue.

I get this

$ rpm-ostree status
State: idle
● fedora:fedora/36/x86_64/silverblue
                  Version: 36.20220812.0 (2022-08-12T00:59:25Z)
               BaseCommit: dbed4341222fe62a21389ce58bf192e6e167faf5e1c7ff64960f3f2e3c00dba4
             GPGSignature: Valid signature by 53DED2CB922D8B8D9E63FD18999F7CBF38AB71F4
          LayeredPackages: easytag-nautilus ffmpeg gstreamer1-libav
                           gstreamer1-plugin-openh264 gstreamer1-plugins-bad-freeworld
                           langpacks-it sushi
            LocalPackages: rpmfusion-free-release-36-0.2.noarch

                  Version: 36.20220808.0 (2022-08-08T00:44:29Z)
               BaseCommit: 2a4756e2374156fb939a65cb6a47c1a75c327e0896ea7cad6c747346b09a0a51
             GPGSignature: Valid signature by 53DED2CB922D8B8D9E63FD18999F7CBF38AB71F4
          LayeredPackages: easytag-nautilus ffmpeg gstreamer1-libav
                           gstreamer1-plugin-openh264 gstreamer1-plugins-bad-freeworld
                           langpacks-it sushi
            LocalPackages: rpmfusion-free-release-36-0.2.noarch

What do you get if you do an rpm-ostree update?

$ rpm-ostree update
2 metadata, 0 content objects fetched; 788 B transferred in 6 seconds; 0 byte content written
Checking out tree f6f49b4... done
Enabled rpm-md repositories: fedora-cisco-openh264 fedora-modular updates-modular updates fedora rpmfusion-free-updates-testing rpmfusion-free phracek-PyCharm google-chrome rpmfusion-nonfree-nvidia-driver rpmfusion-nonfree-steam updates-archive
Importing rpm-md... done
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2022-08-25T20:02:23Z solvables: 4
rpm-md repo 'fedora-modular' (cached); generated: 2022-05-04T21:12:01Z solvables: 825
rpm-md repo 'updates-modular' (cached); generated: 2022-08-26T12:45:01Z solvables: 1419
rpm-md repo 'updates' (cached); generated: 2022-08-26T11:40:37Z solvables: 22838
rpm-md repo 'fedora' (cached); generated: 2022-05-04T21:16:11Z solvables: 67992
rpm-md repo 'rpmfusion-free-updates-testing' (cached); generated: 2022-08-26T16:40:26Z solvables: 3
rpm-md repo 'rpmfusion-free' (cached); generated: 2022-05-04T04:48:11Z solvables: 506
rpm-md repo 'phracek-PyCharm' (cached); generated: 2022-08-24T04:55:21Z solvables: 5
rpm-md repo 'google-chrome' (cached); generated: 2022-08-25T16:43:39Z solvables: 3
rpm-md repo 'rpmfusion-nonfree-nvidia-driver' (cached); generated: 2022-08-24T16:15:41Z solvables: 30
rpm-md repo 'rpmfusion-nonfree-steam' (cached); generated: 2022-08-24T16:15:54Z solvables: 2
rpm-md repo 'updates-archive' (cached); generated: 2022-08-26T12:18:24Z solvables: 33549
Resolving dependencies... done
Will download: 2 packages (477,0 kB)
Downloading from 'rpmfusion-free'... done
Importing packages... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
Running posttrans scripts... done
Writing rpmdb... done
Writing OSTree commit... done
Staging deployment... done
Freed: 47,7 MB (pkgcache branches: 0)
  NetworkManager 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  NetworkManager-adsl 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  NetworkManager-bluetooth 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  NetworkManager-config-connectivity-fedora 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  NetworkManager-libnm 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  NetworkManager-ppp 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  NetworkManager-wifi 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  NetworkManager-wwan 1:1.38.2-1.fc36 -> 1:1.38.4-1.fc36
  SDL2 2.0.22-3.fc36 -> 2.24.0-1.fc36
  atkmm 2.28.2-3.fc36 -> 2.28.3-1.fc36
  buildah 1.26.2-2.fc36 -> 1.26.4-2.fc36
  containers-common 4:1-56.fc36 -> 4:1-59.fc36
  cpp 12.1.1-1.fc36 -> 12.2.1-1.fc36
  cups 1:2.4.2-3.fc36 -> 1:2.4.2-4.fc36
  cups-client 1:2.4.2-3.fc36 -> 1:2.4.2-4.fc36
  cups-filesystem 1:2.4.2-3.fc36 -> 1:2.4.2-4.fc36
  cups-ipptool 1:2.4.2-3.fc36 -> 1:2.4.2-4.fc36
  cups-libs 1:2.4.2-3.fc36 -> 1:2.4.2-4.fc36
  dbus-broker 31-1.fc36 -> 32-1.fc36
  distribution-gpg-keys 1.75-1.fc36 -> 1.76-1.fc36
  ethtool 2:5.18-1.fc36 -> 2:5.19-1.fc36
  fedora-gpg-keys 36-1 -> 36-4
  fedora-repos 36-1 -> 36-4
  fedora-repos-archive 36-1 -> 36-4
  fedora-repos-modular 36-1 -> 36-4
  fedora-repos-ostree 36-1 -> 36-4
  firefox 103.0.1-2.fc36 -> 104.0-5.fc36
  freerdp-libs 2:2.7.0-1.fc36 -> 2:2.8.0-1.fc36
  gdk-pixbuf2 2.42.8-3.fc36 -> 2.42.9-1.fc36
  gdk-pixbuf2-modules 2.42.8-3.fc36 -> 2.42.9-1.fc36
  geocode-glib 3.26.3-1.fc36 -> 3.26.4-1.fc36
  git-core 2.37.1-1.fc36 -> 2.37.2-1.fc36
  gjs 1.72.1-2.fc36 -> 1.72.2-2.fc36
  glib-networking 2.72.1-1.fc36 -> 2.72.2-1.fc36
  gnome-bluetooth 1:42.2-1.fc36 -> 1:42.3-1.fc36
  gnome-bluetooth-libs 1:42.2-1.fc36 -> 1:42.3-1.fc36
  gnome-desktop3 42.3-1.fc36 -> 42.4-1.fc36
  gnome-desktop4 42.3-1.fc36 -> 42.4-1.fc36
  gnome-remote-desktop 42.3-1.fc36 -> 42.4-1.fc36
  gnome-shell 42.3.1-1.fc36 -> 42.4-1.fc36
  gtk4 4.6.6-1.fc36 -> 4.6.7-1.fc36
  ibus-libpinyin 1.12.91-1.fc36 -> 1.13.0-1.fc36
  kernel 5.18.16-200.fc36 -> 5.18.19-200.fc36
  kernel-core 5.18.16-200.fc36 -> 5.18.19-200.fc36
  kernel-modules 5.18.16-200.fc36 -> 5.18.19-200.fc36
  kernel-modules-extra 5.18.16-200.fc36 -> 5.18.19-200.fc36
  libbluray 1.3.1-1.fc36 -> 1.3.2-1.fc36
  libdnf 0.67.0-2.fc36 -> 0.68.0-1.fc36
  libgcc 12.1.1-1.fc36 -> 12.2.1-1.fc36
  libglvnd 1:1.4.0-2.fc36 -> 1:1.4.0-4.fc36
  libglvnd-egl 1:1.4.0-2.fc36 -> 1:1.4.0-4.fc36
  libglvnd-gles 1:1.4.0-2.fc36 -> 1:1.4.0-4.fc36
  libglvnd-glx 1:1.4.0-2.fc36 -> 1:1.4.0-4.fc36
  libglvnd-opengl 1:1.4.0-2.fc36 -> 1:1.4.0-4.fc36
  libgomp 12.1.1-1.fc36 -> 12.2.1-1.fc36
  libjaylink 0.2.0-4.fc36 -> 0.3.0-1.fc36
  libkcapi 1.3.1-4.fc36 -> 1.4.0-2.fc36
  libkcapi-hmaccalc 1.3.1-4.fc36 -> 1.4.0-2.fc36
  librepo 1.14.3-1.fc36 -> 1.14.4-1.fc36
  libreport-filesystem 2.17.1-1.fc36 -> 2.17.2-1.fc36
  libstdc++ 12.1.1-1.fc36 -> 12.2.1-1.fc36
  libtracker-sparql 3.3.2-1.fc36 -> 3.3.3-1.fc36
  libwinpr 2:2.7.0-1.fc36 -> 2:2.8.0-1.fc36
  llvm-libs 14.0.0-1.fc36 -> 14.0.5-1.fc36
  m17n-db 1.8.0-25.fc36 -> 1.8.0-26.fc36
  man-pages-it 4.14.0-1.fc36 -> 4.15.0-2.fc36
  mesa-dri-drivers 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mesa-filesystem 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mesa-libEGL 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mesa-libGL 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mesa-libgbm 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mesa-libglapi 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mesa-libxatracker 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mesa-vulkan-drivers 22.1.5-2.fc36 -> 22.1.7-1.fc36
  mozjs91 91.12.0-1.fc36 -> 91.13.0-1.fc36
  mutter 42.3-1.fc36 -> 42.4-1.fc36
  openldap 2.6.2-2.fc36 -> 2.6.2-3.fc36
  openldap-compat 2.6.2-2.fc36 -> 2.6.2-3.fc36
  pango 1.50.8-1.fc36 -> 1.50.9-1.fc36
  plocate 1.1.15-3.fc36 -> 1.1.16-2.fc36
  podman 4:4.1.1-3.fc36 -> 4:4.2.0-2.fc36
  podman-gvproxy 4:4.1.1-3.fc36 -> 4:4.2.0-2.fc36
  protobuf 3.19.4-2.fc36 -> 3.19.4-6.fc36
  qemu-guest-agent 2:6.2.0-13.fc36 -> 2:6.2.0-14.fc36
  rsync 3.2.4-1.fc36 -> 3.2.5-1.fc36
  selinux-policy 36.13-3.fc36 -> 36.14-1.fc36
  selinux-policy-targeted 36.13-3.fc36 -> 36.14-1.fc36
  skopeo 1:1.9.0-4.fc36 -> 1:1.9.2-1.fc36
  tracker 3.3.2-1.fc36 -> 3.3.3-1.fc36
  twolame-libs 0.3.13-19.fc36 -> 0.4.0-1.fc36
  tzdata 2022a-2.fc36 -> 2022c-1.fc36
  vim-data 2:9.0.137-1.fc36 -> 2:9.0.246-1.fc36
  vim-minimal 2:9.0.137-1.fc36 -> 2:9.0.246-1.fc36
  webkit2gtk3 2.36.6-1.fc36 -> 2.36.6-2.fc36
  webkit2gtk3-jsc 2.36.6-1.fc36 -> 2.36.6-2.fc36
  wireplumber 0.4.11-2.fc36 -> 0.4.11-3.fc36
  wireplumber-libs 0.4.11-2.fc36 -> 0.4.11-3.fc36
  zlib 1.2.11-31.fc36 -> 1.2.11-32.fc36
  gstreamer1-libav 1:1.20.3-1.fc36 -> 1:1.20.0-1.fc36
  gstreamer1-plugins-bad-freeworld 1:1.20.3-1.fc36 -> 1:1.20.0-1.fc36
Run "systemctl reboot" to start a reboot

it seems it worked :man_shrugging:

1 Like

no, it didn’t

I rebooted and the update of Firefox from 103.0.1 to 104.0 is still proposed to me

1 Like

I’m running F36 WS and FF is version 103.0.2, the Fedora repo is likely lagging behind Mozilla somewhat I would think.
edit: I just noticed an update is pending and FF is included in it.
You could try to do a rpm-ostree cleanup -m then the update again.

It doesn’t look like that’s the issue. 104 was in the staged update. This might be the recent issue where rpm-ostree finalize and/or grub2-makeconfig is needed to actually boot to the updated image.