Can't see volumeicon on i3bar - Fedora 34 i3 spin

I’m using Fedora 34 i3wm - which I like very much! The only issue I have is that I can’t display the volume icon on the i3bar. I’ve done a lot of customising, but I noticed that problem before I started.

If I type volumeicon & at the command line, then it appears. However, if I include it in ~/.config/i3/config, it doesn’t. This is not serious, but it is a bit annoying.

Here’s the line in the config file:

exec --no-startup-id volumeicon &

I’ve tried it with and without “sleep” (5 and 10), and have also tried to use exec-always, but that didn’t help either.

I’ve totally changed the i3bar, to make use of conky, but, as I mentioned, I had noticed this issue before I started. Here is the code for my bar:

conky.config = {
background = false,
cpu_avg_samples = 2,
no_buffers = true,
out_to_console = true,
out_to_x = false,
own_window = false,
update_interval = 1,
short_units = true,
total_run_times = 0

conky.text = [[

{“full_text”: " | “, “color”:”#555555"},
{“full_text”: “CPU: ${cpu cpu0}% “, “color”:”#cf6a4c”},
{“full_text”: " | “, “color”:”#555555"},
{“full_text”: “RAM: $mem”,“color”:“#cda869”},
{“full_text”: " | “, “color”:”#555555"},
{“full_text”: “LAN: ${addr eno1}”,“color”:“#89b859”},
{“full_text”: " | “, “color”:”#555555"},
{“full_text”: “Wifi: ${wireless_essid wlp2s0}”,“color”:“#00aaaa”},
{“full_text”: " | “, “color”:”#555555"},
{“full_text”: “BATT: ${battery}”, “color”:“#9b703f”},
{“full_text”: " | “, “color”:”#555555"},
{“full_text”: “UP: ${uptime_short} “, “color”:”#838184”},
{“full_text”: " | “, “color”:”#555555"},
{“full_text”: “${time %A %Y-%m-%d}”, “color”:“#cccccc”},
{“full_text”: “${time %H:%M}”, “color”:“#cccccc”}


I should mention that the network icon appears (to the right of the time) which allows me to switch Wifi routers, as do the icons for seafile and seadrive. But not the volumeicon!

Any help would be appreciated. Thanks.


Does it show up when playing music or watching a movie?
Does it work if you put it in .xinitrc?

Thanks for your reply. It doesn’t show up while playing music.
It does appear briefly (on and instantly off) while booting up.
I’ve tried .xinitrc, and that didn’t help. I even put @reboot sleep 90 && /usr/bin/volumeicon into crontab (grasping at straws) but that also didn’t work. It’s not the end of the workd… it’s just odd. I tried out Devuan and it worked there… but the network icon didn’t!
I guess you can’t have it all :rofl:

Can you try with just volumeicon without the &?

volumeicon -d hw:0 &
volumeicon -d hw:1 &


That worked! Thanks so much!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.