Can't install VLC

I am trying to install the VLC flatpak but it isn’t working. I’m trying to install it from the website I thought you could install flatpaks on Silverblue?


Open a terminal and type

flatpak install org.videolan.vlc

flatpak install org.videolan.vlc
It will not work if you have not already added the Flathub repo to Silverblue. The 3rd Party Repo toggle on initial install curates Flathub to 5 apps…

Hey @apollo18 Go ahead and add the Flathub repo again by doing the following :


After that you should be good to go to install VLC

I am curious to learn why in source it says: “Local file” (Flatpak)

Also, why does VLC even show up in Software, when flathub is not yet set up as repository?


minor correction:

flatpak install org.videolan.VLC

(…with capital VLC, that makes a difference but of course has nothing to do with the issue of the OP)
(see Flathub—An app store and build service for Linux)

I downloaded the file and tried to install it using Software from my SSD.

That isn’t really isn’t the best way to install a flatpak. You should enable the repository in flatpak and then install directly from the repository.


Yeah, I see that now. I enabled the repository and now flatpaks install from the Terminal. I’m still learning.

1 Like

… and Gnome Software, right?

When you first install Fedora, you ge the option to add 3rd party Repos ( Including Flathub )

As is the evidence in the Software Center

but Fedora Filters this and only allows 6 apps to get through, ( MS Teams, Zoom, Minecraft, Discord, Postman, Skype )

So you have to add the Flathub repo again. . . This is VERY confusing for new users as i have documented on another thread. Honestly needs someone to rethink this methodology.


Yes, that is confusing but thankfully there is a community willing the help new users sort it all out.

1 Like

Let’s hope someone takes notice. . . :clap: