Can't install or upgrade VirtualBox 7.0 guest additions on Win10 VM

I am running Windows 10 on VirtualBox 7.0 from RPMFusion. I have the virtualbox-guest-additions-7.0.6-1.fc37.x86_64 installed, but for some reason Windows is stuck with version 7.0.4. If I try to install or upgrade it from VirtualBox’s own menus, it says it needs to download the ISO image, but then aborts saying that there was an “unknown error during certificate downloading”.

Last time this happened I managed to work around this by manually downloading the ISO from VirtualBox’s site (which is surprisingly hard to find), and then “inserting” this as a virtual optical disk, but this is clearly not how it was supposed to be done.

Any clues on what could be wrong on my setup?

I don’t know about the rpmfusion version as I use the latest from the virtualbox site but the guest additions I download from the site to the downloads folder then right click the folder and use the open with virtualbox option and have had no issues.

What you mean is the extension pack, right? That is different from the guest-additions

Your right was not paying attention.Maybe time to get my old eyes checked.

This package is for Fedora running as a VirtualBox guest.
It is useless on a Fedora host or a Windows guest.

I’m afraid that’s the way since the ISO is not included in the VirtualBox RPM.

1 Like

You have to do it in the guest ist selves. Just check that virtualbox has the version you like to have.
The iso should be updated automatically.
You just have to use the " Insert Guest Additions CD image option":


Did you try the Virtual Machine Manager ? Since then I never used the Virtualbox again.
No more play around with the guest additions.

That explains it all :wink: In fact, right after I sent the first message, I removed it to see if it changed anything, and it didn’t. Thanks for the explanation!

That’s how I have always done it in the past, but for some reason it doesn’t work anymore (it says it can’t download the ISO).

Mmmh… not really, thanks for the tip, I guess I’ll have to give it a try to see how it goes. Are you aware of any issues running Windows 10 as a guest OS?

Almost not used windows since I said goodbye to it. I would like to have a minimal image were i could use some software, but without all the crap who comes with it. Unfortunately I always removed it again because of the size of it.

If you now such a image i will test it and give feedback for you. I also never went back to Virtualbox because the integration into the OS is much better with the Virtual Machine Manager. As you use Nvidia i can’t tell you how good this works with it.

Ok, remembered an issue. You need the english version to use the wireless or Network in general. At least with Boxes I read about it.

When using qemu everything works, and is fast. Why someone should make things unnecessary harder using virtualbox instead of qemu with virt-manager, or boxes, or cockpit, which are already installed?

Hi @caesar , that’s a fair point. I once tried Windows 10 on Boxes, and it was not a good experience (can’t recall exactly why, though). I would definitely ditch VirtualBox and use any of this readily available alternatives if I am sure they work fine with Windows 10. Have you tried it already?

“Fair” is a bland euphemism. Try it and you will see. Here you can see my proof.

I decided to migrate from W10 to Fedora a month ago and have converted my old windows installation into an image just in case. It took 5 minutes to start it in KVM. Everything works fine!

I have noticed a recommendation to change CPU topology from default to 1 socket 2-3 cpus 2 threads in Chris Titus videos, and VMs indeed seem to run better.
Give KVM a try! Virtualbox is type 2 hypervisor and will run much slower.
Just sudo dnf install @virtualization (if you are not on Silverblue).


Thanks @andym , based on your and @caesar ‘s feedback, I will definitely give it a try. I watched Chris Titus’ videos, and it looks really promising.

Just a quick update: I created a VM for Win10 using virt-manager, and thanks to the valuable resources posted here (and some others), installation and configuration were a breeze. Everything is working just fine, and I will be able to drop VirtualBox entirely. So, big thanks to everyone that replied here, especially @caesar and @andym , for opening my eyes :wink:

Even though this is not a solution for the original problem per se, I will mark this post as a solution considering I now have at my disposal a much better alternative than VirtualBox.