Can't enable fingerprint reader authentication to true

Hello everyone. I’m using Nobara 38, a modified version of Fedora with some scripts and tweaks to allow better performance on gaming and content creation.

I just installed a fresh install but noticed that the fingerprint reader option isn’t available on Gnome settins.

I confirmed that the fingerprint reader does work with fprintd-enroll.

After some digging, I noticed

[paul@nobara-pc ~]$ cat /etc/authselect/dconf-db
# Generated by authselect on Sun Jun 25 23:00:28 2023
# Do not modify this file manually, use authselect instead. Any user changes will be overwritten.
# You can stop authselect from managing your configuration by calling 'authselect opt-out'.
# See authselect(8) for more details.


Just as the notes said, editing the file manually didn’t work. So I naturally tried editing it via Dconf. The option was


But For some reason, I cannot actually change the setting.

Can anyone help with this strange situation? Thanks!

Fixed. I just found the authselect command
sudo authselect enable-feature with-fingerprint

1 Like