Can't create new files on Local HDD

So my system has 2 local drives. a SSD and HDD. SSD is working find no problem there if you may wonder. But ever since my installation my HDD wont permit me to create new files. I tried reinstalling the OS and a hard choice, to format it but still to no avail.


Tried even the terminal way too. and troubleshooted in chmod. But can’t access on chmod as well

Can we see the output of findmnt --real and an ls -ld of the directory you are trying to create a file in?

1 Like

Try logging on as root before making your dir, then change ownership with:
chown tuturu177013:tuturu177013 tuturu177013

Here it is. Sorry if its a bit late


I tried su - root. But it wont authenticate me. Which is honestly weird.

That looks like a link to a local file. We can’t see that.

1 Like

Sorry my mistake.

It looks like it is only writable by root.

Try to chown it again and share the output from chown command.

Can you guide me in using the chown command? sorry, im new to linux.

sudo chown -R username:username /path/to/directory

Replace username with your actual username and replace /path/to/directory with the full path to the directory.

That will chown the directory and everything inside of it. Be cautious not to use it one the wrong directory.

1 Like


I think since my HDD wont even let me create new files means that the dir is closed??

For more context, my file manager is the defaut “files” of fedora. And the local drive that im trying to access is on "+Other Locations and is below “On this computer”
I can access and see the drive. But cant create new files on it. Thats my main concern honestly.

Your username doesn’t include the @fedora part. That is probably your hostname.

Also, that probably isn’t the full path…

You don’t have permissions to it. That is what the chown fixes.

Interestingly. i cant seem to make proper dir on my working local drive as well. But i can create new folders on it though. I’ll test what i can do for now though or if im just that dumb.

Ok… Just found out that my terminal wont show the FULL directory. This is honestly problematic

You mean in the prompt?

You can make it show you the full path but then the prompt would get huge.

The command pwd will show the path of the directory you are currently in

1 Like

Ok i tried the previous command ```
sudo chown -R username:username /path/to/directory

with all the correct username and the dir that showed on pwd. Still no cigar.

I'm about to jump ship in ubuntu. Ill update you if its working fine in ubuntu and if it does then ill stay there.

Hey man. No problem no ubuntu on my side. Thanks for sticking out to me. At least i learned a few commands interacting with you

There is a good reason to copy-paste the text and avoid screenshots whenever possible.

1 Like

Oops, command should have been:
chown tuturu177013:tuturu177013 dir