Can't access hard drive from live cd

Need help please
I updated to fedora 31 (from 30, in software update)
The update did not succeed and I can’t boot since (I get a blinking cursor).
I tried using a live cd (boot from USB) to access files on the hard drive but it either shows empty folders or won’t let me access the drive at all. Probably because I’m not logged in. How can I access the files on my hard drive or fix the boot issue?

You’re right, liveuser from Live CD session doesn’t have the rights to access you files or system files. The easiest way to access files you need is becoming superuser in the terminal – the same as you’d do it on a normal fedora system:

sudo -i

Also note you can install Midnight Commander from Live CD session to navigate files/folders from the terminal in a more graphical way:

sudo dnf install mc

To launch it with root’s rights use

sudo mc

One other useful thing in such a situation is using chroot. It’s a way to essentially login to your installation from another system (Live CD session in this case). Be careful with it though: you’ll have rights of a root – and it’s very easy to mess up your system this way.
You need to follow steps in this doc up to step 8 to enter chroot in your Fedora installation. You’ll need to use correct partition names if you used custom partition layout when installing Fedora:


Many tnx. But I managed to do so from Windows 10 using a 3rd party software to access fedora file system

1 Like

Actually, it’s very easy to do from Live CD / USB. I’m sure you’ll be comfortable with it once you’ve tried once.

Aside from this – whichever works for you :slight_smile:

1 Like