Cannot upgrade Fedora Silverblue Rawhide

I have an issue where the software center shows updates are available. When I select Restart & Upgrade, the system seems to upgrade okay. When the system comes back up I enter my encrypted passphrase and then halts at a message stating the root account is locked.

I have rolled back and can log into desktop. I cleaned up the metadata and tried again. Same issue.

How can I move forward applying updates without getting root account locked. I’m stuck at 20211109.n.0 The update to 20211111…n.0 and 2021113.n.0 both failed this way.

Any help or suggestions would be greatly appreciated.

The root account is by default locked. If you want it unlocked you will need to go to a command line (open terminal window) then use the command ’ sudo passwd root ’ to set a password for the root user. Once that is done then the account will no longer be locked and you will be able to use ’ su ’ to switch to the root user or login as the root user.

I am not familiar with silverblue since I do not use it, but that will take care of the ‘locked’ root account.

This won’t work on Silverblue.
You could try an rpm-ostree cleanup - p to cleanup any pending transactions then try the update again. I don’t see your issue here Issues · coreos/rpm-ostree · GitHub. You may want to report it there since it does seem like something got squashed on during the commit process.


I will try that. It seems on every attempt to update this happens. I have cleaned up all deployments and fell back to Silverblue 35 release. I have that system up and running fine. Even the updates worked.

I will rebase back to rawhide (36) and see what happens. Then pin my Silverblue 35 release so I don’t loose it.

I’m not sure if something has happened in the last update of rawhide. It was updating fine. I had tried installing to another flash drive from a freshly downloaded ISO, and the latest update did the same thing.

Also, it would not finalize. So I used sudo ostree admin finalize-staged

Will post follow up.