Cannot set nvidia card to 100Hz

I am trying to set my monitor to its supported 100Hz but it is either not allowing me to (going up to 90Hz) or half the screen is distorted. It used to work but it got problematic after some update…

Here is some system details:

 # inxi -G
 Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] driver: nvidia v: 440.64 
            Display: server: Fedora Project 1.20.6 driver: nvidia tty: N/A 
            OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64

# glxinfo |grep "direct rendering"
direct rendering: Yes

# lsmod |grep nvidia
nvidia_drm             57344  9
nvidia_modeset       1118208  17 nvidia_drm
nvidia_uvm           1097728  4
nvidia              20471808  829 nvidia_uvm,nvidia_modeset
drm_kms_helper        233472  1 nvidia_drm
drm                   585728  12 drm_kms_helper,nvidia_drm
ipmi_msghandler       118784  2 ipmi_devintf,nvidia

I have a slightly different card and the results of inxi -G are a little different.


[quote]inxi -G
Graphics: Device-1: NVIDIA GP107 [GeForce GTX 1050] driver: nvidia v: 440.64
Display: x11 server: Fedora Project 1.20.6 driver: nvidia resolution: 1920x1080~75Hz
OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64
Notice that I show a Display: entry and a resolution: entry while yours shows a blank Display entry and a tty: entry.
Are you doing this on a tty? or with the display manager running?
are you using wayland or X11?

my lsmod and glx info is the same.

I allowed my monitor and card to auto-negotiate the settings for freq, and the resolution is exactly what the monitor is designed for.

nvidia packages I have installed are

[quote] dnf list ‘*nvidia*’
Last metadata expiration check: 1:07:23 ago on Sun 29 Mar 2020 12:19:56 PM MDT.
Installed Packages
akmod-nvidia.x86_64 3:440.64-1.fc31
kmod-nvidia-5.5.10-200.fc31.x86_64.x86_64 3:440.64-1.fc31
kmod-nvidia-5.5.11-200.fc31.x86_64.x86_64 3:440.64-1.fc31
kmod-nvidia-5.5.9-200.fc31.x86_64.x86_64 3:440.64-1.fc31
nvidia-modprobe.x86_64 3:440.64-1.fc31
nvidia-persistenced.x86_64 3:440.64-1.fc31
nvidia-settings.x86_64 3:440.64-1.fc31
nvidia-xconfig.x86_64 3:440.64-1.fc31
xorg-x11-drv-nvidia.x86_64 3:440.64-2.fc31
xorg-x11-drv-nvidia-cuda.x86_64 3:440.64-2.fc31
xorg-x11-drv-nvidia-cuda-libs.x86_64 3:440.64-2.fc31
xorg-x11-drv-nvidia-devel.x86_64 3:440.64-2.fc31
xorg-x11-drv-nvidia-kmodsrc.x86_64 3:440.64-2.fc31
xorg-x11-drv-nvidia-libs.x86_64 3:440.64-2.fc31

All the above are from the rpmfusion repo.

All are done within XFCE.

I just used the default but how could one verify if it’s wayland or X11 running?

My installed packages is a bit different:

# dnf list '*nvidia*'
Last metadata expiration check: 0:33:52 ago on Sun 29 Mar 2020 21:08:14 BST.
Installed Packages
akmod-nvidia.x86_64                                                     3:440.64-1.fc31                                @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-5.5.10-200.fc31.x86_64.x86_64                               3:440.64-1.fc31                                @@commandline                   
kmod-nvidia-5.5.11-200.fc31.x86_64.x86_64                               3:440.64-1.fc31                                @@commandline                   
kmod-nvidia-5.5.9-200.fc31.x86_64.x86_64                                3:440.64-1.fc31                                @@commandline                   
nvidia-settings.x86_64                                                  3:440.64-1.fc31                                @rpmfusion-nonfree-nvidia-driver
nvidia-xconfig.x86_64                                                   3:440.64-1.fc31                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                                              3:440.64-2.fc31                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                                    3:440.64-2.fc31                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                                      3:440.64-2.fc31                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686                                           3:440.64-2.fc31                                @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                                         3:440.64-2.fc31                                @rpmfusion-nonfree-nvidia-driver
Available Packages
akmod-nvidia-340xx.x86_64                                               1:340.108-1.fc31                               rpmfusion-nonfree-updates       
akmod-nvidia-390xx.x86_64                                               3:390.132-4.fc31                               rpmfusion-nonfree-updates       
kmod-nvidia.x86_64                                                      3:440.64-1.fc31                                rpmfusion-nonfree-nvidia-driver 
kmod-nvidia.x86_64                                                      3:440.64-1.fc31                                rpmfusion-nonfree-updates       
kmod-nvidia-340xx.x86_64                                                1:340.108-1.fc31                               rpmfusion-nonfree-updates       
kmod-nvidia-390xx.x86_64                                                3:390.132-4.fc31                               rpmfusion-nonfree-updates       
nvidia-modprobe.x86_64                                                  3:440.64-1.fc31                                rpmfusion-nonfree-nvidia-driver 
nvidia-modprobe.x86_64                                                  3:440.64-1.fc31                                rpmfusion-nonfree-updates       
nvidia-persistenced.x86_64                                              3:440.64-1.fc31                                rpmfusion-nonfree-nvidia-driver 
nvidia-persistenced.x86_64                                              3:440.64-1.fc31                                rpmfusion-nonfree-updates       
nvidia-query-resource-opengl.x86_64                                     1.0.0-6.fc31                                   fedora                          
nvidia-query-resource-opengl-lib.i686                                   1.0.0-6.fc31                                   fedora                          
nvidia-query-resource-opengl-lib.x86_64                                 1.0.0-6.fc31                                   fedora                          
nvidia-settings-390xx.x86_64                                            390.132-1.fc31                                 rpmfusion-nonfree-updates       
nvidia-texture-tools.i686                                               2.0.8-21.fc31                                  fedora                          
nvidia-texture-tools.x86_64                                             2.0.8-21.fc31                                  fedora                          
nvidia-texture-tools-devel.i686                                         2.0.8-21.fc31                                  fedora                          
nvidia-texture-tools-devel.x86_64                                       2.0.8-21.fc31                                  fedora                          
pcp-pmda-nvidia-gpu.x86_64                                              5.0.3-3.fc31                                   updates                         
xorg-x11-drv-nvidia-340xx.x86_64                                        1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-340xx-cuda.i686                                     1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-340xx-cuda.x86_64                                   1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-340xx-devel.i686                                    1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-340xx-devel.x86_64                                  1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-340xx-kmodsrc.x86_64                                1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-340xx-libs.i686                                     1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-340xx-libs.x86_64                                   1:340.108-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx.x86_64                                        3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-cuda.x86_64                                   3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-cuda-libs.i686                                3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-cuda-libs.x86_64                              3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-devel.i686                                    3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-devel.x86_64                                  3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-kmodsrc.x86_64                                3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-libs.i686                                     3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-390xx-libs.x86_64                                   3:390.132-1.fc31                               rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-cuda.x86_64                                         3:440.64-2.fc31                                rpmfusion-nonfree-nvidia-driver 
xorg-x11-drv-nvidia-cuda.x86_64                                         3:440.64-2.fc31                                rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-cuda-libs.i686                                      3:440.64-2.fc31                                rpmfusion-nonfree-nvidia-driver 
xorg-x11-drv-nvidia-cuda-libs.i686                                      3:440.64-2.fc31                                rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-devel.i686                                          3:440.64-2.fc31                                rpmfusion-nonfree-nvidia-driver 
xorg-x11-drv-nvidia-devel.i686                                          3:440.64-2.fc31                                rpmfusion-nonfree-updates       
xorg-x11-drv-nvidia-devel.x86_64                                        3:440.64-2.fc31                                rpmfusion-nonfree-nvidia-driver 
xorg-x11-drv-nvidia-devel.x86_64                                        3:440.64-2.fc31                                rpmfusion-nonfree-updates

It’s X11:

$ loginctl show-session $(awk '/tty/ {print $1}' <(loginctl)) -p Type | awk -F= '{print $2}'

IIRC when I first switched to the nvidia card there were problems with wayland and nvidia not playing well in the same sandbox so I had to force my system to use nvidia and X11 by blacklisting the nouveau driver in the boot settings as well as doing something to the x11 settings.
Later updates of wayland and x11 made it so when the nvidia drivers were loaded the system automatically used x11 so that problem is a thing of the past, but still I suspected you were using x11 because of the nvidia card.

However, this still does not directly address the original issue in that you asked about setting the video to 100hz refresh.

As I recall from my experiences during bygone years, different video cards used different frequencies to match with different resolutions on the older CRT type monitors and on some of the early flat-screens. Some not-so-small number of video cards were sacrificed to the quest for higher resolutions than the hardware could support, as it was often a trial-and-error configuration for graphical displays in the early 90s. Often the same video card could support different resolutions on the same monitor depending on the frequency selected.

Most people nowadays just go with the default auto-config settings, but maybe you can experiment a little to see what is possible if you are not happy with the auto settings.
I have seen posts where the settings for the lowest resolution monitor have to be selected when 2 different monitors are attached to the same video card.

Seem that a dnf remove xorg-x11-drv-nouveau did and is keep doing the trick so far… I can set it to 100Hz and the setting will keep after reboot.

That may be a bug you should file. Nouveau has had a lot of problems with nvidia cards and if just having it installed on your system prevents the video card from operating properly I would see that as an issue.
The nouveau driver has been modified recently to have less interference with nvidia but seems it still is not fully fixed.

and half the screen was flickering after a couple of reboots… It seems that it “stabilizes” at 95Hz.

Does your compositor support refresh rates beyond 60Hz (or beyond refresh rates which are multiples of 60Hz)? If not then a (refresh rate % 60) frames would be skipped/interpolated to give you the choppy feeling.