Cant run my 4k tv at 1440p_120hz

I recently installed Fedora32 on a 2nd pc, I intend for this system to be a game stream box to my Samsung RU8000 65" TV. This pc has a Geforce gtx770 installed and in Windows I can run it in 1440p/120 with no issue. I installed the NVIDIA driver from rpm-fusion instead of using the installer from NVIDIA. Everything works but I can only do 60hz at 1440p, I can select 1080p and 120hz is avaialble, does anyone have an idea? I created a xorg.conf file and tried adding 2560x1440_120 to the modeline and it had no effect.
Thanks in advance.

The default config after a RPMFUSION install is very “boring” and safe. Are u able to open nvidia-settings inside the enviroment and tweak some of the settings ? Can u share what driver and fedora version are u using too ?

nvidia settings works, I tried setting the refresh in the nvidia-settings panel with no effect.

uname 5.8.15-201.fc32.x86_64
NVIDIA 455.28 driver

Not sure if its relevant but I’m using a DVI-HDMI adapter for the TV.