Cannot permanently disable proxy

I set up proxy and now I cannot disable it even after using unset. When I open a fresh terminal session the proxy is again set.

I have tried to search various /etc/* and ~/.* files for the proxy variable but i cannot find it. Please help me to turn this off.

Check the output:

gsettings list-recursively org.gnome.system.proxy
sudo grep -i -r -e proxy= /etc /root ~/.bash*

for the first command the output was-

org.gnome.system.proxy autoconfig-url ''
org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8', '::1']
org.gnome.system.proxy mode 'manual'
org.gnome.system.proxy use-same-proxy true
org.gnome.system.proxy.ftp host '172.31.102.29'
org.gnome.system.proxy.ftp port 3129
org.gnome.system.proxy.http authentication-password ''
org.gnome.system.proxy.http authentication-user ''
org.gnome.system.proxy.http enabled false
org.gnome.system.proxy.http host '172.31.102.29'
org.gnome.system.proxy.http port 3128
org.gnome.system.proxy.http use-authentication false
org.gnome.system.proxy.https host '172.31.102.29'
org.gnome.system.proxy.https port 3128
org.gnome.system.proxy.socks host '172.31.102.29'
org.gnome.system.proxy.socks port 3128

and for the next command the output was-

/etc/nfs.conf:use-gss-proxy=1
1 Like

:gear: GNOME Settings > Network > Proxy > Off

gsettings reset org.gnome.system.proxy mode

thanks man, really nice of you, can you briefly explained what was wrong?

Nothing is wrong, this is normal proxy configuration on GNOME: