Cannot connect to Xfinity internet | Fedora 40 |

Hi all, I recently upgraded to Fedora 40 workstation coming from windows 11 and am currently having issues staying connected to the internet. For context: My ISP is Xfinity (Comcast) and I am connected to a desktop via ethernet. I saw on a forum of a related issue that if you can ping it is a DNS issue( I will link the forum below). To get the internet to work even for just a little bit (5-10 minutes) I have to restart the router. I was able to ping so it appears to be a DNS issue. I have also tried running “systemctl restart networkmanager” and failed. Does anyone have any solution to this problem?

Added f40, networking and removed workstation

Added networkmanager

Welcome to :fedora:

The first command you entered was wrong, it should look like this and return this :

systemctl status NetworkManager

● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: enabled)
    Drop-In: /usr/lib/systemd/system/service.d
     Active: active (running) since Mon 2024-07-01 09:33:49 EDT; 1h 35min ago
       Docs: man:NetworkManager(8)
   Main PID: 4281 (NetworkManager)
      Tasks: 4 (limit: 33415)
     Memory: 8.9M (peak: 10.0M)
        CPU: 1.029s
     CGroup: /system.slice/NetworkManager.service
             └─4281 /usr/sbin/NetworkManager --no-daemon

You can use this command with start, stop, restart & enable

When you said “You can use this command with start, stop, restart & enable” are you referring to replacing the “status” with one of those mentioned above?

Also, the picture included is what I get when running this command.

That is correct, in your first attempt it looks like you used restart just not the right NetworkManager

Roger that, so what would be the best option to use for my situation? Enable?

According to the picture you provided, it’s active and running. I’m no expert in the networking area of Linux, so some other memeber will chime in surely.

Ok, thank you for all your help.

If the problem is just DNS, then just switch to a different DNS provider. Try following these instructions. If that solves your problem, then great.

However, Comcast should have reliable DNS and needing to disable it sounds unusual. You’re sure you don’t have malware on your router?

No malware that I’m aware of. If I restart the router: I’ll have internet temporarily, but I’ll have to keep restarting the router just to keep a connection going. It’s done similar things on windows, but after troubleshooting last night: windows is able to hold a connection for much longer (if not indefinitely) than linux. I’ll try those instructions you referenced and see how they work for me.

Followed the steps in the link you referenced. No joy. It’ll stay stuck in a “connecting” status instead of a “unknown connection” status and then eventually just stops trying to connect.

Do any other devices work on it ? Do they have the same effect ? Connected/disconnect.

Not going to recommend a reset, since that might cause some issues with your ISP, but if other devices also have issues could be hardware?

Since you’ve made this post: it has been holding connection for over an hour which is great. To answer your question: I did order a new router yesterday incase it was the router.

That no longer appears to be the case. Since I applied the steps Michael linked (I’ll link them below) and reset the router and restarted the computer, it has been holding a connection. So, for now as long as I am maintaining a connection: I am good.

:sunglasses: :+1:t5:

IDK, but if you get a new one soon might as well check/keep it and send this one back.