Cannot boot FW33 after moving swap partition

I have a FW33 installed on /dev/sda2 and swap partition on /dev/sda4.
For some reason I wanted to clear the /dev/sda4.

In Gparted app I deactivated /dev/sda4, deleted it, created a new swap on /dev/sda5 on extended partition, than activated /dev/sda5 as a new swap.
But at this moment I accidentally rebooted the computer.

Now FW33 cannot boot, it stops looking for the old swap on /dev/sda4 which is not there.
Please how do I re-link FW33 with the new swap partition on /dev/sda5?

I tried to boot live distro Rescatux, mounted to /dev/sda2, modified /etc/fstab to have correct UUID of new swap partition, but the comments in fstab file say:
“After editing this file, run ‘systemctl daemon-reload’ to update systemd…”
but I cannot do this command, if I will not boot into FW33, am I right?
Is there a solution?

Thank you for support!

1 Like

Boot a Fedora live session, mount the rootfs and go to chroot:

# Check the current partition names and UUIDs
lsblk -o +FSTYPE,UUID

# Edit the configs to match the current settings
sudo -e /etc/default/grub /etc/fstab

# Regenerate GRUB configs and initramfs
sudo grub2-editenv create
sudo grub2-mkconfig -o /etc/grub2$(test -d /sys/firmware/efi && echo -efi).cfg
sudo dracut -f --regenerate-all

As a further note: the systemctl daemon-reload command is only necessary to make changes take place on the running system immediately. If you are repairing from a rescue CD, there is no need — the changes will take place when the system boots.

@vgaetera thanks a lot, you saved me! I did exactly, what you have written and it worked. My FW33 is now up and running.
I appreciate your help!


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.