Can I compile Fedora Media Writer on Windows aarch64

I’m running Windows 11 on my Galaxy Book S. Has anyone tried to compile the Media Writer on aarch64 Windows? I’ve been trying to boot into Fedora 41 aarch64 (doesn’t currently work) but I need to create the bootable USB on a separate laptop (running Fedora 40 on x64). It’d be nice if I could create the bootable media on my Galaxy book,

I have not tried that. However, the media writer is only a convenience. You can download the ISO and use something else to write it the USB.

Is it really F41 (rawhide), or did you mean F40? For aarch64 systems there is no ISO download available on Fedora’s download page, but for F40 it is still available here.

Balena Etcher is a nice tool to flash ISO images, available on Windows too, but it seems they don’t have aarch64 executables either. Rufus maybe?

Thanks Mike, I did try 40 but this doesn’t work. I noticed that Quallcom is putting in a lot of code for the latest kernel and noted that Fedora 41 is using this latest kernel and it actually does boot to a degree before panicking subsequently freezing up (so it seems more promising than 40).
I’m downloading the image from here:
Back on subject though, I’ll see if I can download a tool that might be compatible with aarch64. I’ll check out Rufus as you suggested to start with. Thanks for your input :slight_smile:

1 Like

Thanks Dalto, I’ll see if I can find an alternate tool that might be compatible.

rufus has an arm64 version. I am not sure if that is compatible with your hardware or not.

Yep, that one worked :slight_smile: