Bug with displaying programs

Good evening.
After updating and installing Fedora Workstation 39, many programs began to display incorrectly. For example: Microsoft Edge, Yandex browser, Shortwave. I haven’t checked all the programs. I uploaded a screenshot, what could be wrong? Before the update everything worked fine.

Are you using an nvidia GPU?

If so then you probably have the same issue I did recently. The system-upgrade reboot process does not wait long enough before rebooting to allow the nvidia drivers to be compiled and installed.

You can try to reboot again. If that does not fix it then at the login screen use ctrl-alt-F3 and log in using text mode. Then do the following
sudo dnf remove kmod-nvidia-\*
followed by sudo akmods --force and wait about a minute after that last command completes before rebooting.

If you are not using nvidia GPU and the nvidia drivers then this is not useful.


Good Evening.
I am using the integrated graphics controller of an AMD Ryzen 7700 processor.

Here is information about GPU:
lspci | grep -E “VGA|3D”`
14:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raphael (rev c3)

I had similar issue with apps running but doesn’t display in Wayland at all. Can you try if problem will also be visible in Xorg? There was one package that has been pulled out in beta stage of F39. Your system is updated? Try running “dnf distro-sync” and see if there is something that dnf want to revert to older version?

1 Like

Thanks for the advice!
The latest updates have been installed.
There was just a problem with Xorg, I switched to GNOME and now the applications launch correctly.
It’s strange that in Fedora 38 all applications worked correctly under Xorg.

Actually gnome is used with both xorg and wayland.
Did you mean that you switched to using gnome on wayland?

We can see that answer with the output of inxi -Gxx to show the graphics config.

1 Like

Yes, sorry. I switched to wayland gnome at system startup. You’re right.

Снимок экрана от 2023-11-09 23-24-44

Without using the inxi utility, I looked in the settings.
Снимок экрана от 2023-11-09 23-27-39