Bug: Emojis rendered black/white in most KDE apps

I was already thinking about replacing them with the Twemojis or Apple Emojis, but found out the Google Noto Color emojis are already installed and work.

The only App they work in though, is the KDE Emoji picker. All other apps how black-white outlined emojis. Any reason for this?

On OSTree I can also not overwrite the emojis, which is a bit sad.

Hi - looks like some other KDE users have had similar issues that came down to needing to set system fonts - perhaps this is related?

1 Like

There was this idea:

#Just create the following config file:  

`~/.config/fontconfig/fonts.conf`:

    <?xml version='1.0' encoding='UTF-8'?>
    <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
    <fontconfig>
     <alias>
      <family>serif</family>
      <prefer>
       <family>Noto Sans</family>
       <family>Noto Color Emoji</family>
      </prefer>
     </alias>
     <alias>
      <family>sans-serif</family>
      <prefer>
       <family>Noto Sans</family>
       <family>Noto Color Emoji</family>
      </prefer>
     </alias>
     <alias>
      <family>monospace</family>
      <prefer>
       <family>Noto Sans</family>
       <family>Noto Color Emoji</family>
      </prefer>
     </alias>
     <dir>~/.fonts</dir>
    </fontconfig>

Problem is this seems to be exact settings available in KDEs settings. What is missing is a feature “use Font X for all symbols” “use emoji font y for all missing ones”.

Also afaik the noto sans font has these b/w emojis integrated, so there wouldnt be emojis missing actually.

When I set Noto color emoji as standard font it looks horrible. There are numbers, spaces and more included that look very bad. It is not only the emojis thats the problem.

I havent found a way to unpack the font file and combine “Noto Sans + Noto color emoji” or other combinations like Ubuntu.

This would still be an annoying workaround, I would include it in our Fedora Ostree setup script but 1. Googles font needs to have symbols removed 2. KDE needs to allow multiple fonts at once.

1 Like

This seems to be a Qt issue

https://bugreports.qt.io/browse/QTBUG-85744

A fix seems to be nearly done.

Added f39, f40, fonts, kde, kde-plasma, qt

Added bug-reported

From Ask Fedora to Proposed Common Issues