Bug dm-crypt password saved in qwerty

Hello!
I’m new here, I’m under GNU/Linux since 99, and under Fedora since 2014. I’m trying Silverblue (I love the idea of LibOSTree).
Under the Rawhide version downloaded yesterday (after long hours…) I’ve found a bug, my french AZERTY keyboard was sucessfully detected after I’ve selected “French” language in the first screen of Anaconda (fr-oss in the top right corner), so my dm-crypt password was filled in AZERTY, but after the reboot, it’s don’t works, I need to enter it as if it was filled in QWERTY.

There is an issue tracker for reporting this issue please?

1 Like

https://github.com/fedora-silverblue/issue-tracker/issues :smiley:

This seems a bit like this bug, which should have since been fixed. What do you get if you run cat /etc/vconsole.conf?

It’s because with rpm-ostree the initramfs (dracut) run is server side by default, and so the keyboard layout in the initramfs is fixed. It’d probably work around this to enable client-side regeneration via rpm-ostree initramfs --enable.

The better fix though is probably for rpm-ostree/dracut to learn how to gather any potential local changes like this and overlay the default initramfs.

Glad to see this, as this hit me quite hard, the first time I installed Silverblue. That forced me to reinstall my whole system for three times, until I found out about the changed keyboard layout!

I use a special German keyboard where all letters are interchanged – not just one or two, like it’s the case in most ?WERT? layouts.

I also filed some bug reports for this issue (among others), but it’s pretty daunting that nobody seems to care even a bit about Plymouth issues, especially with having the great rework throughout the last cycle…
https://bugzilla.redhat.com/show_bug.cgi?id=1582345
https://bugzilla.redhat.com/show_bug.cgi?id=1629350

1 Like

Hello,
Just give few times again to try Silverblue, now with the official release 30 and the bug is still present !
I suppose Silverblue is still not ready for international users so.
Any idea of when Silverblue will not be reserved to QWERTY owners please?

Hi @zyklon
What is your recommendations to start using Silverblue with a non-QWERTY keyboard ?
Currently, I’ve installed Silverblue with AZERTY french keyboard, but on reboot I need to fill the password as if my keyboard was set on QWERTY.
Do you think I could continue like that and hope a bugfix in the future, where my password layout will be correctly set to AZERTY ?
Or, is it better to re-install Silverblue, in QWERTY layout, but filling my password as if the layout was AZERTY, then on next reboot I can fill my password correctly with my AZERTY keyboard ?
This second solution cause me some worries, because may be one day, Silverblue developer will finally fix the problem and on reboot my layout will be set again to QWERTY.

All advices are welcome !
Thanks

You could try rpm-ostree initramfs --enable like @walters had said.

Yep you’re right, when I’ve reported the issue I’ve forced to remove my Silverblue installation so I haven’t found time until this week to give a new try to Silverblue.

This morning I’ve reinstalled Silverblue with 2 layouts installed (default us + fr-oss) with the hope to use the special keys to switch between them also on the boot. The switch key works in Anaconda and inside Fedora but not on the dm-crypt boot.

Here is the results of cat /etc/vconsole.conf :
$ cat /etc/vconsole.conf
KEYMAP=“fr-oss”
FONT=“eurlatgr”

$ sudo rpm-ostree initramfs --enable
[sudo] Mot de passe de guillaume :
Checking out tree c77995e… done
Enabled rpm-md repositories: fedora updates
Updating metadata for ‘fedora’… done
rpm-md repo ‘fedora’; generated: 2019-04-25T23:49:41Z
Updating metadata for ‘updates’… done
rpm-md repo ‘updates’; generated: 2019-05-23T17:37:23Z
Importing rpm-md… done
Resolving dependencies… done
Checking out packages… done
Running pre scripts… done
Running post scripts… done
Writing rpmdb… done
Generating initramfs… done
Writing OSTree commit… done
Staging deployment… done
Freed: 1,6 Go (pkgcache branches: 0)
Initramfs regeneration is now: enabled

I rebooting… results here in few seconds :slight_smile:
EDIT: Still in QWERTY for the boot password :frowning:

My keyboard in fact is QWERTZ, I just soft-switch it by default to Neo2. So at boot, I just type in the letters like they’re shown on the keys. When booted into the OS, Neo2 is active and the keys then don’t map anymore to what you get when you press them… :stuck_out_tongue:

Ok thanks for your answer.
So currently there is no solution. I’ll continue to fill it as if my keyboard layout was in qwerty, and hope a fix could be done in when Silverblue will release a stable version for every users.