Rebased to Fedora 39 Silverblue: No Keyboard

Hi There,

i tried to rebase my Steam Deck from F38 to F39, my disk is encrypted with Luks Password. But unfortunately, booting F39 is impossible, because my keyboard isn’t recognized so i can’t enter my Luks Password. Booting F38 is still possible (i love silverblue). Is there a way to temporarily remove the password or provide it as a kernel boot parameter, so i can pass them to Luks during boot.

Any help would be greatly appreciated.

This is weird. Can you give us the output of rpm-ostree status after rebasing but before you reboot?

Hi @siosm , i did a complete reinstall with fedora 39. Strange, the initial deployment just works fine, but after doing an rpm-ostree upgrade, the new staging lacks also on some USB Drivers. I’m using a Steam Deck, this device have only one USB-C Connector with an i-tec UUSB Dock attached. I’ve tried attach my Cherry USB Keyboard directly through an Adapter to the deck with no avail.

Heres the output from rpm-ostree status:

migadmin@steamdeck:~$ rpm-ostree status
State: idle
                  Version: 39.20231117.0 (2023-11-17T00:55:33Z)
               BaseCommit: 4eb66a63032dea860e4338a9e2b69051df3fabd5568390689c408f95f85f7800
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C
                     Diff: 363 upgraded, 3 removed, 12 added
          LayeredPackages: langpacks-de

● fedora:fedora/39/x86_64/silverblue
                  Version: 39.1.5 (2023-10-31T22:06:37Z)
                   Commit: 3f6c3c54e77690b576ced4cf01528b8415a691bcf5afbe5df203b046ff396c67
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C

I think the kernel messages are also interesting to compare, they’ll show the difference… But where should i post them? Fedora’s pastebin has only a time of one day - or one reading. in short:
while Version 39.1.5’s kernel (6.5.6) Message grep -i “kernel: usb” counts ~181 lines, there are only ~32 lines in Version: 39.20231117.0 (Kernel 6.5.11).

A sidenote: There is another issue, it looks like anaconda creates an wrong entry if you install Fedora Silverblue with luks. The generated args-string for luks om my machine:

But this is not an uuid, this is the luks-name, after correcting this to rd.luks.uuid=bfae1e13-a39d-4885-b28a-9ae63d6ec3fb, my added rd.luks.key arg works as expected. Yeah, this is another issue and should be reported through bugzilla, though.

You might want to take a look at Bazzite or at least for a known workaround there as they make specific images for the Steam Deck.

1 Like

Wow, i wasn’t aware of this project. But guess what: i have the very same issue with Bazzite, even with the Deck Image.

The Bazzite image is supposed to work well on the Deck so this suggests that you issue is somewhere else.

found the issue thanks to the Bazzite community. It’s the upstream Kernel/AMD Driver, a Bug report has been placed by others.

Workaround on Steam Deck is to switch from USB-DRD to XHCI in it’s firmware settings.

See also [Steam Deck] USB-C DRD makes all external USB comms unavailable on latest Linux kernel (#2984) · Issues · drm / amd · GitLab

1 Like