Browser (brave) being repeated on all desktops

Hello there!

Since I got some problems sith SELinux, and some package conflicts, on the upgrade from F37 to F38 Beta, I decide to do a fresh install.

On problem that I had with F37 is where randomly on opening ?Brave, it would repeat the open window on all my desktops, on F38 it’s almost everytime. and not just hown on the minituare of the desktop but also on the desktop. If I change rotate all of them in all of them the window would be there.

Never got it happening with Firefox or any other program.

I don’t use GNOME, but on KDE, a setting allows showing a window on every virtual desktop. Maybe there’s such a feature in GNOME too?

Also, does this happen only with Brave? Is this a classic installation, or is it installed using Flatpak?


I’m not aware of a “repeat window feature” on Gnome nor Extension. It doesn’t happen with Firefox, but I use Brave much more. Trying to get back to Firefox. Maybe is a Chromium based browser bug with Gnome. I’m currently using only Flatpak browsers. I thought it could be related to Acceleration, but it happens with it enabled or not.

Hmm, have you checked the command that launches the browser? Again, I’m unfamiliar with GNOME, but I believe there should be an option to edit the launcher entries somewhere.

If you’re familiar with using the terminal, you can check the .desktop file directly (I too have Brave installed with Flatpak):

$ cat /home/$USER/.var/app/com.brave.Browser/data/applications/com.brave.Browser.desktop

[Desktop Action new-private-window]
Exec=/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=brave com.brave.Browser --incognito
Name=New Incognito Window

[Desktop Action new-window]
Exec=/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=brave com.brave.Browser
Name=New Window

[Desktop Entry]
Comment=Access the Internet
Exec=/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=brave --file-forwarding com.brave.Browser @@u %U @@ --enable-features=UseOzonePlatform,WebRTCPipeWireCapturer --ozone-platform=wayland
GenericName=Web Browser

Even running via command line I got the same problem. BUT, it looks like a profile bug. I tested with my other profile, thought it could be the number of tabs, since the other one has just 4; tried with a bunch of tabs; as it did not happen, I created a blank profile, used Brave Sync, restored all tabs and, for now it is not happening.
I have to login to each account again and will keep testing with the new profile.