Broadcom wireless driver fails to get loaded after upgrade from F38


I always prefer to stay one version behind. So, I was on Fedora 38 (sway spin), and since F40 is out, I upgraded to F39 from F38. and it went smooth (as always). except the wifi wasn’t working. so I thought it might got solved in F40, so I upgraded to F40… same thing, no luck.

Btw, my hardware is an old MacBookAir-mid-2013.
So when I debugged the issue, I found that the wl module somehow wasn’t built correctly.

When I tried to load it manually by modprobe wl, it said:

modprobe: FATAL: Module wl not found in directory /lib/modules/6.8.7-300.fc40.x86_64

I tried akmods --force --kernel $(uname -r) --rebuild and it solved the issue.

I am posting this, in case anyone has the same issue I had
and, for the developer team, to investigate it.

Best regards

The broadcom-wl driver is from a 3rd party repository (likely RPMFusion, but other sources exist).

As Fedora does not provide the driver, you should open an issue with the maintainers of the package(s) you are using.


I have a couple of affected machines. These have drivers from third party sources. I have this problem with each Fedora version upgrad. The simple fix is
sudo depmod