Broadcom 4312 issues

@nightromantic @FranciscoD
Thanks for the suggestions on how to possibly accomplish this offline

However, now I have a wired connection I have downloaded the rmpfusion rpms.
I then installed broadcom: dnf install broadcom-wl
I powered down, I disconnected the Ethernet cable
I power up…still no wireless.

The system tells me that Broadcom is installed:

root@localhost useru]# dnf install broadcom-wl
Fedora Modular 30 - x86_64 24 kB/s | 23 kB 00:00
Fedora Modular 30 - x86_64 - Updates 35 kB/s | 22 kB 00:00
Fedora 30 - x86_64 - Updates 27 kB/s | 23 kB 00:00
Fedora 30 - x86_64 28 kB/s | 24 kB 00:00
RPM Fusion for Fedora 30 - Free - Updates 45 kB/s | 10 kB 00:00
RPM Fusion for Fedora 30 - Free 48 kB/s | 10 kB 00:00
RPM Fusion for Fedora 30 - Nonfree - Updates 26 kB/s | 9.6 kB 00:00
RPM Fusion for Fedora 30 - Nonfree 50 kB/s | 10 kB 00:00
Package broadcom-wl- is already installed.
Dependencies resolved.
Nothing to do.

Curiously though, at the installation the last line said unable to open broadcom-wl-

My ip a:

    [useru@localhost ~]$ ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: enp14s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
        link/ether 3c:07:71:62:1e:fd brd ff:ff:ff:ff:ff:ff
    3: wlp0s20u1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether 50:3e:aa:d2:0d:4d brd ff:ff:ff:ff:ff:ff
    4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
        link/ether 52:54:00:df:cd:56 brd ff:ff:ff:ff:ff:ff
        inet brd scope global virbr0
           valid_lft forever preferred_lft forever
    5: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 1000
        link/ether 52:54:00:df:cd:56 brd ff:ff:ff:ff:ff:ff

@medfed, from my own experience, at least some Broadcom chipsets have to have proprietary firmware for them to work. I’m not sure about your exact one, it have to be verified. I just paint you overall picture so that you can understand what to look for.

Later either someone else can tell us for sure about your chipset, or you yourself will do the research, or maybe I’ll get some time to find the information for you.

I had such an issue with builtin wireless chipset on my (quite old) laptop, which I rarely use now.

So with my Broadcom chipset it was like this:

  1. It needs proprietary driver – which cannot be shipped by Fedora as it isn’t opensource or as it requires proprietary components. This driver I’ve got from rpmfusion, and maybe it was the same broadcom-wl as you’ve installed.

  2. I have to say, that maybe – I don’t remember now as I did it quite some time ago – after several releases of Fedora I could get it up without installing another driver from rpmfusion, but I definitely still needed step 3 for wireless to work.

  3. For driver itself to work it needed proprietary firmware. I had to install another packet from rpmfusion, it was called something like firmware cutter, then using instruction (from either readme or Internet) I’ve downloaded windows driver for this wireless card and exctracted firmware from it. Firmware files had to be placed into /usr/lib/firmware/ for driver to see it. Then you needed to either reload driver or reboot for wireless to work.

I have to say, information was quite easy to find. Also it’s not Fedora-specific, it was the same for any Linux distribution with my WiFi chipset.

I don’t give you package names or enter this, do this instructions as I don’t know for sure if it’s all the case with your chipset. I think this information can be useful for you, and you can do a bit of research yourself to understand, do you need extracted firmware or not. Also I myself find it very useful to have background information to understand why I need to do something )

If you find any such info but need the help with the process – please say so.

If you absolutely cannot find yourself any definite information, or if my case with firmware isn’t applicable to your chipset, then either someone else who knows for sure will tell us, or I myself will try to find info about your chipset later.

Edit: It looks like broadcom wl driver for BCM43142 wireless chipset (and others) DOES NOT require getting/installing additional firmware I described in step 3. I don’t have any chipsets supported by broadcom-wl so I can’t verify it myself.

Also if anyone interested i think (not sure now) that driver I used – which did require getting firmware – was b43 – another Broadcom driver for (presumably) older chipsets.

@nightromantic, thanks for your detailed assistance and pointing me in the right direction(s). Bullet three was now of particular interest to me now. Per bullet one, I did follow the Command Line Setup ( Per bullet 2, I have the same result; I can install the driver (dnf install broadcom-wl) but, as you know, have no connection. Per bullet 3 It appears that in order to get the firmware one must now download the rpmfusion Tainted package and install, as shown here:
And then use command: dnf install b43-firmware

This firmware has installed successfully. I rebooted. I’ve now reinstalled the driver (dnf reinstall broadcom=wl) as recommended and am about to reboot. I’ll see you on the other side…

1 Like

I’ve gone through the replies here, and from the looks of it we haven’t checked what exact wireless hardware you have. When you do get the chance @medfed, could we have information on the broadcom hardware please? This should do it:

lspci -v | grep -i -A10 wireless
1 Like

I’m not getting any output:

[root@localhost useru]# lspci -v | grep -i -A10 wireless
[root@localhost useru]#

…still no wireless. Just to be sure, I am unplugging the Ethernet cable from the modem to my laptop and reinserting the (original) cable to the router.

Odd. So, if the system can’t see your wireless module, it’s expected that wireless doesn’t work.

How do you know you are using a broadcom wireless module then? Is there a hardware switch on the system somewhere? If you tell us the make and model of your machine, we may be able to find the specifications somewhere online.

PS: should we move all the wireless related talk to a new topic?

Only from outputs like:
07:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)

On the this specs page^ it states the right technology
IEEE 802.11b/g/n

And this page^^ mentions Broadcom Corporation BCM43142 sony vaio fit wifi. fedora20; a Linux although that model is a SVF1521K4E and not a SVF1521K6E


I already asked the true owner of the laptop - in case there was a sneaky one somewhere - but she said that there isn’t one.

Sony SVF1521K6E

Sure. Do I start the new topic?

1 Like

Oh, have I misunderstood something here? I don’t know about the module.

Right, lsmod shows rtl8xxxu for the dongle (TP-Link TL WN823N RTL8192EU) but nothing resembling bcm4xxxx (BCM43142 802.11b/g/n) - if I’m at all onto anything there!

1 Like

I moved the relevant posts to a new topic here.

So, I found some information on getting broadcom 43142 to work. Try this:

sudo dnf install kernel-devel kmod-wl akmod-wl broadcom-wl

Reboot and see what you get?

There are reports that this only works if “secure boot” is disabled in the BIOS settings, since the driver here is unsigned. We can look into that bit if the above doesn’t work.

To clarify a bit @FranciscoD’s post, it’s enough to install

sudo dnf install kernel-devel kmod-wl

as kmod-wl will get akmod-wl and broadcom-wl packages (and all the other stuff it needs) as dependencies.

Also this version of the driver seems to not require additional firmware installation which b43 broadcom driver did.

If you don’t have wireless working after reboot, it’s useful to verify that the driver is loaded:

sudo lsmod | grep wl

Output should look something like this, it shows that we have wl driver (kernel module) loaded:

wl                   6463488  0
cfg80211              806912  5 wl,mac80211

If it doesn’t show anything, then wl kernel module isn’t loaded, we’ll have to understand why.

Also it can be useful to check output of dmesg, it can contain useful hints for why your wireless isn’t working:

dmesg | grep wl

Output for me is:

[96041.972617] wl: loading out-of-tree module taints kernel.
[96041.972619] wl: module license 'MIXED/Proprietary' taints kernel.
[96041.974664] wl: module verification failed: signature and/or required key missing - tainting kernel

No error reports, just some warnings about tainting kernel, which is expected. Note I actually don’t have any Broadcom chipsets, your output should contain some lines about actually enabling the wireless device, something like (this is an example):

[    4.705725] wl 0000:03:00.0: enabling device (0000 -> 0002)
[    4.767470] wl 0000:03:00.0 wlp3s0: renamed from wlan0
1 Like

One more thing I’ve found totally by chance:

@medfed it maybe the case it affects you too – you’ll have to test it yourself. The solution is in the article.

1 Like

No joy I’m afraid, even after reboot.

I rebooted again to go into BIOS, and disabled “secure boot”. I still have no wireless but what is interesting is this:

Before the BIOS change the wireless option was NOT distinguished between USB and PCI, i.e., it only ever read: Wi-Fi Not Connected

OK, that looks like progress. So, what happens when you click on PCI wifi and try to select a network?
Could we have the output of these commands please?

sudo lsmod | grep wl

dmesg | grep wl

nmcli dev

nmcli con

Driver is loaded:

[root@localhost /]# lsmod | grep wl
wl                   6463488  0
cfg80211              806912  2 wl,mac80211

Per dmesg, I have the same output:

    [root@localhost /]# dmesg | grep wl
    [   27.651416] wl: loading out-of-tree module taints kernel.
    [   27.651421] wl: module license 'MIXED/Proprietary' taints kernel.
    [   27.653757] wl: module verification failed: signature and/or required key missing - tainting kernel

But nothing about enabling, only:

    [   27.744334] wl 0000:07:00.0 wlp7s0: renamed from eth0

So does this mean that the wireless is enabled?

1 Like

It looks like it is enabled. Also screenshot you’ve posted earlier is showing your computer seeing two wireless cards (usb one and pci i.e. built-in one too).

Please post here output of

and try to connect to your wifi network with PCI WiFi, as @FranciscoD suggested.

1 Like

The same Connection Failed message; this after chosing my network. But what’s interesting is that, on choosing my network, the signal strength shows itself to be strong whereas before it was always weak.

As requested, nmcli dev & nmcli con:

nmcli dev shows us computer sees two wireless devices with names wlp0s20u1 and wlp7s0.

This is good ) Though sadly this is not always 100% guarantee you can connect using these devices.

I suggest

  1. Unplug your USB wireless adapter so that it won’t confuse us.

  2. Please apply fix proposed by this link. It involves adding new copr repository and updating or reinstalling one package named wpa_supplicant. Commands you need are in the article.

1 Like

Success! That was a great find, @nightromantic. I’m ashamed to say that the link is second place in my search engine yet I managed to overlook it. I now have wireless through the Broadcom. Thanks to one and all for helping me with this issue.

1 Like

@medfed, glad you’ve succeeded!

Some devices are still problematic to various degree under Linux, wireless cards and some NVidia GPUs are among the worst )

But there are plenty of wireless cards that are just plug-and-play in Linux, you plug them in and they work without any hassle. So when you’ll bee looking for a new one, you can choose one with good Linux support. Also keep in mind that not all the cards that say about Linux support on their package are good.

There are cards with true open-source driver that’s already included in Linux kernel – that’s the good ones. And there are others which have Linux support – but through proprietary driver and some jumps and hoops. The example is Broadcom chipset in you Sony laptop.

To look for good ones you can start from here:

And that page links to this list:

As far as I understand, you can use it to choose devices with good Linux support. And also asking here and on other Linux forums can help to choose a good one)