How do I need to download the Broadcom wireless drivers for Fedora 37?

Hello! I recently installed Fedora 37 on my Dell Inspiron 1525. I boot into Fedora to find that wi-fi is not working, and I have been spending all week trying to figure out what I need to do. My card is the BCM4312 802.11b/g LP-PHY (rev 01) with a PCI-ID of 14e4:4315. After some searching, I found I needed to install the kmod-wl package. I have added the RPM Fusion repositories, removed any previous modules (ssb, b43) and blacklisted them. After installing the package with $ sudo dnf install kmod-wl, I rebooted my computer and wi-fi still wasn’t working. I used $ lspci -vnn to check the modules and found that it still listed ssb as the kernel module. When I tried to remove it ($ rmmod ssb), it said “rmmod: ERROR: Module ssb is not currently loaded”. It doesn’t make sense because I removed those modules and wl should have replaced it. Did I install the package incorrectly or is there just something wrong with the kmod-wl package and I need to try something else?

If you search here you may find that you need to install the broadcom-wl package since it seems that actually contains the driver for that card


I checked if I had it with dnf and it told me that it was already installed. It’s strange since the module isn’t loaded though.

Check some of the other posts about the broadcom drivers. I seem to recall that you might need to blacklist the default module before the newer one can be loaded. I cannot say first hand with no broadcom cards for testing.

Secure Boot requires to enroll the MOK certificate:

sudo systemctl restart akmods.service
sudo mokutil -i /etc/pki/akmods/certs/public_key.der << EOI

See also: README.secureboot - rpms / akmods

Otherwise, make sure Secure Boot is disabled in the BIOS/EFI settings:

mokutil --sb-state

‘sudo dnf install broadcom-wl’ package you need is broadcom-wl and after you done reboot

1 Like