Brave Browser command line not working


I’m trying to make some Web Apps with webapp-manager and I don’t want to use Firefox but Brave.

The problem I’m facing is that Brave is not listed as a possible Browser to choose from in the webapp-manager and the first step from the instructions to add a new browser is to “make sure browser is in the PATH , for example i can run Min Browser with min in terminal”…

xdg-open <file_name> doesn’t seem to be helpful in this case and I’m not sure why but Brave won’t open from a terminal command (I can open Brave like a normal app without any problem, just through the terminal not). I already tried using the System Monitor to find out the name on the terminal (“brave”) and tried all possible variations I could think of (Brave, brave-browser, BraveBroser, Brave-Browser, …).

Has anybody an idea on how can I make it work properly?


Curious - does it work if you create a shortcut within Brave itself (Menu > More Tools > Create Shortcut) and try to launch that? Theoretically that would use a similar method to launch Brave as the web app manager would create?

I believe that is not the same, since one opens as a browser page and the other as an app (I mean also because of Layout and stuff) but that would’t be a solution for me, since it get’s on my apps as another Brave browser that when clicked goes to a webpage…

BTW, is there a way to get rid of that shortcut? Can’t find a way…

I could make a keyboard shortcut to go directly there but I would rather have the feeling of being in an app instead of a web browser, haha

Try using the app name ‘brave-browser’ on the command line. You mentioned you had, but since that works for me, let us know what response you get when you try it.


I get the response:

bash: brave-browser: command not found...

And similar with the variations I already tried:

‘brave browser’
‘Brave Browser’
‘Brave browser’

Is it a flatpak?

Yes. The Flatpak is the only version in my Software Center. I’m not sure if is supposed to be like that…

flatpak run com.brave.Browser

Looking at those instructions I think it will look something like
browsers.append(Browser(BROWSER_TYPE_CHROMIUM, "Brave (Flatpak)", "/var/lib/flatpak/exports/bin/com.brave.Browser", "/var/lib/flatpak/exports/bin/com.brave.Browser"))

I apologize for not considering the possibility Brave had been installed from a flatpak or snap. While I’ve dabbled in both when necessary, I avoid them if there’s an alternate repository or .rpm source for what I need. You do what you’re comfortable with and works well for you, and I’ll open my mind a bit to consider alternatives that are more attractive to those new to the OS.


No reason to apologize, haha. I must admit that I don’t really know much about the differences between Flatpak, .rpm other any other repository…

The thing is also, normally I was choosing rpm by default when I first installed Fedora until two weeks ago or something, that my system crashed and instead I installed Nobara… I’m not sure about it, but I have the feeling that the .rpm repositories are not included in my Software Center but I have no idea how to check it out or fix it and it’s not been a problem until now, haha!

It worked! The problem after that was that everytime I got in the app I had to choose to use Brave as default web browser and had to log in in the app, if it was a Google app it was a problem because I had to use a two factor authorization to log in and so on…

While trying to fix it I read a comment from someone somewhere (sorry, lost it and it was more like a clue than a direct answer) that to avoid some problems with Brave, it is better to install it the “standard way”, so I did. After that I had to follow the instructions to add a new browser to webapp, since it was written “brave” and I needed “brave-browser”

Now it works perfectly and it was even better after the reinstallation because after that I recovered somehow my old configuration (I mean, with the Bookmarks and stuff) and some BAT, haha

The Nobara distro is mostly fedora, but has significant changes. As I understand it they still use the fedora repos, but also add in their own at the same time.

for future reference:
xdg-settings set default-web-browser com.brave.Browser.desktop

1 Like