Booting with higher resolution console and NVIDIA drivers

I switched from Nouveau to proprietary NVIdia drivers in my Fedora 34 because the former were hard freezing my computer. Now when I boot (always in text mode), the fonts are too big. I tried the usual fixes and did not work.

Following this wiki page, I added


to /etc/default/grub , run grub2-mkconfig -o /boot/grub2/grub.cfg , and reboot. Same ugly resolution.

The 1024x768x16 I got from the output of hwinfo --framebuffer .

I also tried with GRUB_GFXMODE=1680x1050x16,auto , same problem.

Any clues?

For console fonts, I usually edit /etc/vconsole.conf. I think the default is eurlatgr. In my case, this is on a HiRes laptop where the fonts are too small so I change it to ter-v32n. You can see a selection of possible fonts in /usr/share/lib/kbd/consolefonts.

I don’t think the Nvidia stuff will make a big difference in console but this is untested by me with Nvidia.

I don´t think that NVidia driver installation edited this file. And my problem is with the size, not with the font.

Anyway, I don´t have folder /usr/share/lib, but there is a consolefonts folder in /usr/lib/kbd/consolefonts. This helps to choose the font: . But what about the size?

I had this problem many years ago, and solved it. Maybe even before Fedora, with RedHat. I don’t remember what I did, of course. It resurfaced after installing NVidia drivers.

I’m sorry, I mistyped. It should be /usr/lib/kbdconsolefonts/.

I wasn’t clear, so I apologize for that as well. Chosing a font in /etc/vconsole.conf enables you to choose a size. So, if I have ter-v32n it will be size 32, if I want it smaller, and it has a ter-v24n (the files usually have names like /usr/share/kbd/consolefonts/ter-v32n.pfs.gz) then I can use ter-v24n. You can choose the size from any font in that directory. Sorry if that wasn’t clear, but at least with terminus fonts. (on Fedora, you would have install terminus-fonts-console if you want terminus fonts), the size will be in the font name. It is that for some other fonts as well, but definitely with terminus.

Of course you meant /usr/lib/kbd/consolefonts/ :slight_smile:

Oh, I see. I will try those and report back. I thought I needed to lift the resolution of the console, not just the fonts. I am using eurlatgr, that does not seem to have a size option.

I tried lat0-08.psfu.gz and lat0-16.psfu.gz: same sizes.
Tried other fonts, same sizes.
Fonts change, but not their sizes.
My console is still in VGA mode.
This seems to be a resolution problem, not a font problem.