Boot problems after changing SSD

Hello, everybody.

First thing I would like to let you know is that I’m completely new to Linux, and Fedora 32 is my first distro. So, please forgive me if I’m asking something too basic.

I’m using a Dell Laptop (Inspiron 3583) and, when I first installed Fedora 32, everything runned smoothly. But then I got greedy.

Since Fedora was much faster than my previous Windows, I decided to make it faster. So I removed my HDD and installed a SSD (M.2). That’s when my problems started.

At first I got this bug:

Then, I simply updated the system and everything runned smoothly. After a new update, the same error appeared.

Now, I can only boot on my “secure mode” (kernel 5.6.6). Any other kernel that I choose, after I restart the computer, goes back to the same message (Invalid magic).

I’m not a tech guy, despite being an enthusiast, but here’s my rationale:

  • It’s a kernel problem
  • Probably related to the fact that there’s not a HDD installed anymore (despite the SSD being there)
  • If the HDD was necessary, I wouldn’t be able to run secure mode, so it’s possible to work only with the SSD (for energy saving and performance reasons).

So, is there a simple way to fix it (since I’m a newbie)?
I have already tried to:

  1. Re-install (3 times, always the same error)
  2. Update the BIOS (updated, no change)
  3. run “sudo dnf upgrade” (“nothing to do” is the message I get)

Thank you.

I really don’t understand how this could happen. It does not seem a basic question basic at all, but rather quite a special case.

To start investigating, I would suggest you start by investigating the initramfs images when the system is up. Do these steps make sense to you?

  1. Boot with one of the kernels that work.
  2. Start a terminal window
  3. cd /boot
  4. sudo lsinitrd initramfs…

There should be one initramfs for each of the kernels you have installed. Do the lsinitrd command for each of them in turn. I would be curious to know if it works for all of them, or if it too complains about the ones for the kernel versions that start up with the invalid magic message.

This as a start of debugging only.