Boot fails after re-installing

My computer crashed to the point of not booting at all, so I tried re-installing the F 35 Workstation. Now, it boots but reports that it has no access to console and that the root account is locked. I tried using journalctl, but don’t know what to look for or how to interpret it. The laptop is old enough that I may end up needing to replace it, but I’d like to avoid that if possible.

Did you do a legacy install or EUFI install, What model laptop is it? Sometimes the master boot record gets damaged which then prevents the original Linux system from booting.

An easy fix for this is boot into a live USB/CD-ROM disc.

You can do this and easily fix the error which I believe could be the culprit.

So Steps are

  1. Boot into a live Fedora System on your usb or cd.
  2. Open the terminal
  3. Test the layout of the partition by examining the boot and root partition by running this command:
sudo fdisk -l

Depending on your partition setup either LVM or BTRFS there is an easy fix.

Are you able to send a photo of the exact message you get during startup. Sometimes if you regenerate the grub configuration file and reinstall the bootloader into the mASTER boot record can help too

@sideburns Your Fedora installation is fine. The root account is inactive by default in current Fedora installations. So, you have to login with your normal user account. Then, you have to you sudo, e.g., if you want to start parted as root, sudo parted. If you want to activate your root account, you can do it with sudo passwd root which then urges you to enter the new root password. Or use sudo to persistently be in root mode with sudo -s.

In the past, this was different: root used to be activate until some versions ago. If you installed your system before the deactivation of root, yours kept active even when doing the upgrades to the following versions. So, now that you re-installed, you have the current default with root deactivated :slight_smile: Feel free to change it.

I assume you mean that you cannot login as root? As mentioned above, login with your normal non-root user account and then do sudo. If I misinterpreted this, more details about it would be helpful.


Anaconda didn’t ask, or give me a chance to pick what software got installed. It’s a Toshiba laptop, at least ten years old.

You assume wrong. I can’t log in at all. It keeps coming back to the same lines no matter what I do. And, I know how to get to a root password when I need it.

what was the install media ?
the updated F35 media from here ?:

1 Like

As mentioned, without further information such as log files (e.g, use a live system to get them), I cannot help much.

The sole possibility I would include in the evaluation, given your description, is that SELinux kicks you out in each login attempt. It does this when, e.g., critical changes have been made on the fs while it was offline (it assumes a manipulation). You can see this in the log files. If you provide them, we can check that.

If this is the problem, you can start a relabel by creating the file /.autorelabel (e.g., touch /.autorelabel) on the root dir (use a live system). When you reboot after that, SELinux takes some time to relabel, and then it reboots again normally.

Hi, maybe you want also to try with live usb and check your partition layout with lsblk -f. I also have old laptop from 2010 with BIOS instead of UEFI. If we not correctly create partition layout, it will fail on boot (you could also try to chroot it and make some check).

But if you’re sure that current partition layout is correct, in case you’re mounting the /home dir from older installation, make sure you already clean up the old dotfiles there.

No, I got my install media from Get Fedora and used the Workstation ISO. I’m thinking of getting the Xfce spin, as that’s the DE I use, and trying it instead.

Thanx, but this isn’t my first reinstall, it’s just the first to fail this badly. The only change I made to my partition layout is shifting things around to get /boot big enough.

If you means by “shifting” is change the disk sizes after the installation, may be you need to check the UUID of your current fstab.

@sideburns This is the type of change that may make SELinux assume a manipulation and prevent any login… Try the autorelabel (start live system, mount the root partition of your os, create the file as mentioned before) and see whether you can then login again:

If there is a wrong UUID of a system partition in fstab, the system is unlikely to boot up to the login screen. An unmounted /boot also does not prevent a login.

1 Like

No, until I got /boot to be big enough, I couldn’t install. I installed gparted in the live environment, shifted enough free space down to where I could add it to /boot and enlarged that petition before trying again to install.

Could u provide us with the logs? Maybe we can find something. Otherwise, we can only speculate.


have you checked your RAM? Can you rule out that you are bitten by a hardware error? Live System running fine?

Doesn’t mean it’s bad, but in my opinion you shouldn’T use Gnome if you don’t have a min of 8GB RAM and an SSD.
Maybe your laptop would be snappier with one of the lightweight Desktop Environments

Sadly, this feature is only part of the netinstall (, which, unfortunately, is not advertised much.

1 Like

I don’t WANT GNOME; I hate it. I want Xfce, but I’m not giving the choice.

I tried that last night and nothing happened. It just went to that same text screen, and when I reboot into a Live environment, the file’s still there.

Of course you have a choice.
Gnome is the default DE with a workstation install, but you can easily add the xfce DE and use it.


Not on the LiveUSB version you aren’t and that’s all I can get to boot. I’m going to download the Xfce spin, put it on a flash drive and try installing that. At least I’ll start out with the DE I want and won’t have to start off by getting rid of all of that GNOME cruft.

still netinstall, there you have the choice, why live system?